XCOPY in Windows XP syntax problem

  SouthEastRay 06:16 11 Oct 2018
Locked
Answered

I am trying to help someone transfer files from an old XP computer. The files they want are in the system folder Owner's Documents, and although I am pretty comfortable using Xcopy, the syntax is giving me problems eg g:> Xcopy "My computer\Owner's Documents*.* /s" gives File not found - .

I cant see any way to attach a screen shots to clarify, so I have a Google link here Screen Shot showing several attempts.

Any suggestions ?

  Taff™ 08:35 11 Oct 2018

I assume you have booted up the old XP machine or have removed the HDD and attached it to your current computer - describe the set up please.

  SouthEastRay 08:47 11 Oct 2018

Thanks Taff.

I have attached an external USB drive to the Computer = G:, and created a folder called SavedFiles ( which is the "current" folder") Except for the G: drive, the right hand "File Explorer" window is all one machine"

Cheers

Ray

  Taff™ 08:58 11 Oct 2018

Why use Xcopy?

Just use windows Explorer on the machine surely!

  SouthEastRay 09:06 11 Oct 2018

Thats what I first thought too. But Windows XP doesnt have "drag and drop"" on this computer in File Explorer. I know there are even free file utilities for Windows that would be potential options.

The other issue is that I will need to selectively copy files of type "*.bmp", *.dat" etc to different locations, and Xcopy with subdirectory will "weed out" the thousands of files", rather than manually select them.

  Taff™ 09:15 11 Oct 2018

What do you mean by "Doesn't have drag and drop" - XP does! Or select all the folders, right click copy then same to paste to new location. Weeding out those odd file extensions is easily done using a subsequent search for those files and using the search results to delete them all.

  SouthEastRay 09:17 11 Oct 2018

When I right click on the Folder Icon, it just has two options, Cancel or Create Shortcuts here. There is no Copy, Move Delete etc

  Taff™ 09:26 11 Oct 2018

Use a Linux Distro like Ubuntu - boot from a disc and run as a trial from DVD drive using RAM.

  SouthEastRay 09:28 11 Oct 2018

If you dont know Xcopy, thanks. I will keep looking.

  alanrwood 10:25 11 Oct 2018

You quote My computer\Owner's Documents. /s

Should you not have the backslash between Documents and . ie

My computer\Owner's Documents*.* /s

Maybe it is just a typo in your text.

  SouthEastRay 10:32 11 Oct 2018

Oh yes, thanks - a definite typO - that's why I included the screen shot. I have been trying variations of Xcopy "My computer\Owner's Documents*.* /s" I also tried Xcopy "My computer\Owner's Documents*.*" /s Xcopy "C:\Owner's Documents*.*" /s Xcopy "\My Computer\Owner's Documents*.*" /s etc The folder Owner's Documents is some sort of System folder, and doesn't even work using a DIR command. I can't tell if the root folder of it should be C:\, or "My documents\" etc

Very confusing.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sega Mega Drive Mini review: Hands-on

Project Gemini is now Adobe Fresco: Hands-on and release date

macOS Catalina Preview: First look at the new Mac update

Les meilleures enceintes Bluetooth à moins de 150 euros