Windows Installer service stopping

  synthc 20:30 17 Aug 2013

Whenever I try to install or uninstall anything that uses windows installer, the service stops and I get an error from the program I'm trying to install or uninstall. When I open services.msc and go to the Windows Installer service, it is running and then it just stops—always when I try to install or uninstall a program and sometimes at random. The problem started after a failed Net Framework installation. I'm running Windows 7 Ultimate SP1 64 bit.

sfc and Microsoft FixIt are unable to repair Windows Installer; isn't there any other way to repair it besides a clean install?

Things I've tried:

  1. sfc /scannow = "Windows Resource Protection did not find any integrity violations."
  2. Windows 7 repair/upgrade install = unexpected error
  3. checked permissions on HKEYlocalmachine\system\currentcontrolset\services\msiserver
  4. replaced HKEYlocalmachine\system\currentcontrolset\services\msiserver with the regkey folder from a working Windows 7 machine
  5. created a new admin account and tried a windows repair install = same error
  6. stopped and started Windows Installer Service countless times using various methods and tried both manual and automatic startup type
  7. tried setting Windows Installer Service to restart indefinitely after failure
  8. system restore = fails
  9. Windows Installer registry key fix = nothing
  10. Microsoft FixIt = unexpected error
  11. booting in safe mode = no change
  12. Startup Repair = no problems detected
  13. chkdsk /f /r
  14. 2 passes of memtest86
  15. Windows Installer Cleanup Utility
  16. Net Framework cleanup tool

I don't think it's a virus and everything is running fine otherwise. I've tried restoring from an image, but I suspect that the image was made after the problem started occurring (I only discovered this problem when I tried to update Net Framework and Microsoft Visual c++). I'd really rather not do a clean install. Any help would be greatly appreciated.

  synthc 23:13 21 Aug 2013

Solved the problem by uninstalling SP1 and doing a repair install from my Windows 7 disc.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Qu’est-ce qu’Amazon Prime ?