Windows 7 network speed issue

  tomkat2006 16:25 09 Mar 2010

Ive used this hotplug type device for over a year now, no probs. I stream HD content from upstairs to downstairs and roughly got around 8mb/sec which was ideal.

Lately that has dropped to around 5.2mb making streaming stuttering.
The only change is an upgrade to Windows 7, Ive googled and found people have similar problems in general with network transfer speeds, but couldnt find a solution.

However I then tried installing Vista (where it worked fine) and that too has the same speed.

Anyone experience a similar problem, or have any ideas?

A few tests later:

Swapped hotplug
Swapped router
Swapped ethernet cables
moved file from hdd (host) to another hdd
60 foot ethernet cable direct from upstairs pc-downstairs, improved speed from 5.4mb to 9.5mv but STILL LAGGED.

(last speed test using this method was 8mb and 14mb respectively)

--- all same issue

then tried moving the file to a different pc with windows 7 (so windows 7-windows 7) and it streamed a once unplayable (because of lag) movie fine for 18mins until my test ended.

Whats the difference?

A) hdd on working pc not as defragged?
B) Its windows 7-windows 7 instead of the last setup windows 7-windows vista

:Latest update - tried playing a different movie - stutters on the good pc. Played the movie previouslly ran fine for 18mins - stutters.

What the hell!? This is in the space of 30mins.

Does your broadband play any part in this?
Im at a complete loss what this solution is.

AS a note, I tried 3 movies this afternoon at 1:30pm;

Phantom Of The Paradise (stutters ALOT)
St. Trinians

(all 1080)

All play flawlessly on VISTA x64

Logged off, rebooted, went into Windows 7 X64

Played same 3 files at 1:32pm

All stuttered

Tried same test 1hr later; same results.

Tried same test now (3:53pm) same results.
Looks like something to to with W7

Anyone have any thoughts

  Technocrate 06:39 19 Apr 2010

Wow, at first I thought it was 38Mbps and I was thinking "That's not that bad" until I noticed it was KB. I had this exact problem in Windows 7 a few months back when attempting to tweak my dma2100's network performance. When switching one of my adapters to 100Mb full duplex when the rest were 1000Mb full duplex I had speeds very similar to yours.
If you haven't already check the advanced properties of you LAN adapters for all of your PCs on the network.

1. Type "ncpa.cpl" in the start menu to open network connections.
2. Right click on your LAN adapter and choose properties.
3. Click configure, and then the advanced tab.
4. Choose the "Speed & Duplex" option and make sure it's set to 1.0 Gbps Full Duplex on all of your PCs.

If you're using a wireless bridge to join parts of your network you of course won't get 1.0 gbps, but only the speed of the wireless connection. It should still be faster than 38k though

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?