windows 7 - cannot install updates

  awest3 11:39 17 Nov 2016
Locked
Answered

hi, I have a Acer aspire 5738z, with 3gb memory, 250gb hdd, 2.1 ghz processor and windows 7 home premium(SP1) installed. my problem is I can't get ms update to complete, it gets stuck in the 'looking for updates phase'. I've left it running for 2 days to see if it would finish to no avail. I've run update troubleshooter which found a few issues and supposedly fixed them..but no joy. I've reset all the update components several times, used numerous "fixes" off the web, I've even run the offline installer which seems to complete ok but makes no difference. if I look in update history it says update has never been run but if I look in "installed updates" it shows updates from recent times. whilst running update memory is maxed out at 90-100% by something called "SVCHOST.exe(netscvs)" although cpu usage is quite low. I've run Malwarebytes, superantispyware and MSE with nothing found. I've checked that all required services are running. Its takes a while to do all these as its so slow. I've tried all these things in both normal and safe mode. Probably looking at a reinstall of win 7 now but any thoughts gratefully accepted.

  awest3 11:40 17 Nov 2016

forgot to mention whilst running update the cursor seems to have a mind of its own. Jumping across the screen and difficult to control

  awest3 12:00 17 Nov 2016

sorry, keep remembering things I've done.. Ran SFC /scannow . If I try to use the stand alone installer it also gets stuck. A restore wold be the normal place to go but the only restore point this had was from installing win 7 some time ago. However I did try this and managed to then install SP1 over the top...things went downhill form there.

  Govan1x 12:06 17 Nov 2016

have you tried running disk clean up or C Cleaner to get rid of some of the junk. Disk clean up may also get rid of old updates , once you run that anothe pop up will open click on clean up system files and run that. Also check how much disc space you have left.

If using wireless try and connect using an ethernet connection it will download quicker that way.

And do you have SP1 installed.

  Govan1x 12:12 17 Nov 2016

Did sfc /scannow finish without any warnings. if it showed warnings maybe run chkdsk by ticking both buttons so that it fixes any problems that it finds. Then run sfc again.

That can take ages and you cant use your laptop while it is running it.

Noticed that you do have SP1 installed.

  awest3 12:27 17 Nov 2016

thanks for this, yes I forgot to mention ccleaner and there were no warnings at all from SFC. I am using an Ethernet net connection. I've not tried chkdsk so Ill give that a try... thanks again.

  BRYNIT 12:42 17 Nov 2016

It could be a corrupt file in the update folder stopping updates. Have you try running Disk cleanup to delete old update files CLICK HERE for instructions

  awest3 16:48 17 Nov 2016

methinks this is getting sillier and sillier. Whilst its still in searching for updates it comes up with 'you need to restart your computer to finalise updates'. so I do this and it says the usual 'configuring windows etc' then closes and restarts and again configuring windows.. but no updates are added. Stranger and stranger.. I'll try a chkdsk and perhaps a memtest then its a reinstall and start from scratch..although I might try a repair first. I'll let you know.

  awest3 17:11 17 Nov 2016

just thought I'd try 'windows update troubleshooter' one more time. This time it did not come back with any errors and said it had found some updates. I went to windows update and there they are all 154 (730meg). They are downloading as we speak I'll let you know if they install ok.

  awest3 11:16 18 Nov 2016
Answer

After installing the 154 updates another 60 or so became available, catch up, pre-recs and post-recs I suppose. Update procedure is working normally now. The unfortunate part is I have no idea why it suddenly started working. Maybe running 'update trouble shooter' 5-6 times did but I don't really know. So all fixed but not sure why. Thanks for all the ideas on things to try. Al

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6T McLaren edition costs more and charges faster

Artist Yippie Hey on 3D printing a futuristic magazine cover

New Apple Products 2019: Predicting the new Apple products coming soon

Comparatif : PS4 vs Nintendo Switch