Windows 10 Version 1511 - No Internet connection

  tallboy 08:26 29 Dec 2015
Locked

We have two 64-bit Windows 10 installations; one on an almost new i5 desktop and the other on a 2009 Dell Studio laptop. Whilst Windows 10 Version 1511 OS Build 10586.36 works OK on the desktop PC, on the Dell laptop there's no Internet connection if I try & install the same version / build. It comes up with the error message: "One or more network protocols are missing on this computer".

I have tried installing it twice, but get the same error / no connection both times. The network function reports that IPv4 is connected to the Internet but that IPv6 connectivity has no network access.

Does anyone know how to fix this error? For now, I have re-installed the previous version from the image I fortunately made a couple of weeks ago and set Windows 10 to accept critical updates only. As soon as this was installed, the laptop jumped back into life.

I understand from a post on the US Windows Forum site that Dell are not supporting Windows 10 on the Studio PC, so I may have to change the network card to a new one to get Windows 10 functioning with this version. Any recommendations as to a suitable card would also be welcome.

  Fruit Bat /\0/\ 08:44 29 Dec 2015

copy the driver from the good version

update then reinstall the old driver.

  tallboy 10:50 29 Dec 2015

Thanks for the suggestion Fruit Bat. I'll certainly try that. I'll have to make sure I have a secure version of the old driver as the same overwriting will probably happen again on future updates!

Do you know which directory the network drivers are likely to be in?

  Fruit Bat /\0/\ 12:34 29 Dec 2015

how-to-block-automatic-reinstall-of-a-driver

Double driver will back up and restore all your drivers

  tallboy 13:32 29 Dec 2015

Many thanks for the links Fruit Bat. I'll give your suggestion a try.

  tallboy 15:19 19 Jan 2016

I just got around to trying the suggested fix. Double Driver saved the drivers fine and also re-installed them OK, but alas, it hadn't initially fixed the problem. However, after a re-start (quite common for some drivers to install / work correctly) it worked.

Since I wasn't absolutely sure the it was just the Broadcom drivers causing the problem, I restored them all. (Since the oldest should only be July 15 anyway.)

Many thanks for the tip Fruit Bat.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Mi Mix 3 UK Review: Xiaomi's Flagship Slides Into The UK

2019's best up-and-coming illustrators

New Apple Products 2019: Predicting the new Apple products coming soon

Comment utiliser une manette PS4 ou Xbox One sur votre Mac ?