Windows 10 Update - problems after restart

  davidmball9 17:38 10 Dec 2017
Locked

My laptop has just gone through an automatic update to Win 10. It did say it was a major update and could take some time. I restarted on the prompt and left it to it. When I came back, everything was OK, but when I came to shutdown I noticed it still said update and restart. I let it update and restart again and now I have problems. Left click on the the start button does nothing, although I have brief CPU activity. Left click gives me the menu, but not all options are working. I can't get apps or settings, although device manager works. I have lost all my favourites on both chrome and Firefox (Firefox is a different version also - I seem to have lost the most recent update). It has even changed my wallpaper. I have tried restarting in safe mode and a system restore, but it says I don't have any restore points (I have created 2 in the last 6 months). I also tried windows repair, but this did nothing. I upgraded to 10 from 7 on the freebie offer, so I don't have an install disk, so I have not yet tried re-installing windows. Has anybody got any ideas on how to fix this problem?

  Fruit Bat /\0/\ 19:02 10 Dec 2017

Unfortunately windows has this bad habit of switching off system restore when doing a big update - it creates a windows old folder instead which allows to in revert back to the older version for 10 days before deleting it.

You can either revert back using windows settings - recovery or if you read this site you can copy all your files from windows old to the relevant folders in the new version

  davidmball9 21:16 10 Dec 2017

Well, I tried all the options from restoring from an image (no image available), to reverting back to older version ( failed due to an undefined problem). So I had to reload windows, so I have lost all my apps and have to start again and reload them. And of course, my mouse is no longer working, although the touchpad does. I have had this problem before with the creators update, and I think it was solved when I updated windows again. But if you know another way to get my mouse back I would be grateful as I hate using touchpads.

  davidmball9 21:44 10 Dec 2017

Also just looked in the list of removed apps that was created. It has something called Mouse suite. I searched around for this last time, but could not find any way to get the mouse working.

  davidmball9 22:17 10 Dec 2017

Further info. According to the troubleshooter on devices, I have 5 entries of USB controller does not have a driver. Checking in devise manager, that is confirmed as only 2 out of the 7 (the USB 2 entries ) Show divers. I have tried to update drivers. Although Windows finds the driver, it will not install because the installation file is missing a necessary entry. This has happened for all the USB entries. I will download a third party driver updater and try that, but if anyone has any other ideas?.....

  davidmball9 00:34 11 Dec 2017

Tried updating with Driver booster 5. It detected missing drivers but would not load new drivers due to incompatibility. Strangely, my USB WiFi stick works but nothing else does plugged into USB. The uninstalled apps list says the software for the WiFi stick has been removed, but clearly not. My internal WiFi does not work even though windows reports the driver is up to date. I don't have a clue what is going on and there are no automatic updates showing as available when I search, so I can't do an update.

  xania 11:53 11 Dec 2017

I ran this last night and after completing the installation found that it would not recognise my password so had to change it and then discovered that it had completely disabled Norton Internet Security and then crashed and would not reload. Finally managed to restore the previous version and it seems ok. Will not now run on other 2 PC's until someone can assure me that it safe to do so.

  Fruit Bat /\0/\ 13:30 11 Dec 2017

As you have clean installed windows you are going to have to download and install some drivers for your machine.

Therefore we need to know the make and model of your laptop to find the drivers required.

  davidmball9 14:22 11 Dec 2017

Fujitsu Amilo Pi 2515, T5450 @ 1.66Ghtz Core2 Duo. 2 GB RAM 32 BIT Windows.

I have just got home to find my PC has gone through an auto reboot, but stalled with a blue screen and a message "needs to restart but gathering error information 0%" As it was not going anywhere, I manually retarted it. It seems OK but I got a message to inform of Windows feature update and PC needs to restart. This is what happened on my laptop and I am concerned it will screw up my PC also. I have clicked on "remind me in three days" to give me some time.

  Fruit Bat /\0/\ 14:50 11 Dec 2017

"needs to restart but gathering error information 0%" this can take absolutely ages for a big update like the FCU you need to be patient as switching off can really screw the windows update (2 hrs before panicing)

Laptop drivers

click here this should then load the rest of the drivers if ot then use the other link to install the drivers indidually.

click here

  xania 16:36 11 Dec 2017

And here's me thinking that Windows 10 would solve all our problems.

Its Microsoft - stupid.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iPad Air (2019) review

Digital humans aren't just possible - they're essential in today's top games

iMac 21.5in (2019) review

Les meilleures boîtes mails gratuites