Windows 10 is not up dating

  bumpkin 14:47 02 Jan 2017
Locked
Answered

I am using W10 and want it to update. It currently shows no updates installed. I know I turned this off originally for a specific reason but in error I cloned the wrong drive as a backup so I now have 2 that are not updated.

  lotvic 17:46 02 Jan 2017

Have you typed update in the search box and then clicked on Check for Updates in the results and then 'check for Updates' in the new window that opens?

  bumpkin 18:49 02 Jan 2017

Yes I did, I can get to updates OK but it says there are problems try later. Tried it for a few days but same message appears. Update history shows none. Gives this code 0x80070422.

  rdave13 19:51 02 Jan 2017

Right click start, select run and type services.msc. Scroll down to Windows update and right click. Select properties. Startup type should be manual (trigger start). If it is already set to that but doesn't start when you check for updates try starting the service first.

PS you've not set WI-FI connection as metered?

  Govan1x 19:59 02 Jan 2017
Answer

have you tried control panel and clicking on Troubleshooter. then click on updates.

Take it that you have it set to automatic and running in services.

I had the same problem yesterday a brand new laptop and it would not run the updates that were show.

Googling it eventually fixed it for me. there were another two programs in services that had to be set to automatic.

I never had any warnings though. Not sure what the other two programs were but I could hazard a guess which would probably be no good for you.

Now on this W10 computer that I am on i also have to have windows firewall switched on and running or I cannot get any updates. So I have to have two firewalls running.

  Govan1x 20:08 02 Jan 2017

rdave13. [manual (trigger start). I used to have mine set like that when I downloaded the updates manually.

My windows update is always set to automatic now whether that is me that sets it that way I cannot remember.

Took me about 7 hours to get mine to start updating yesterday. Seems there are lots of people out there with the same problem.

  rdave13 20:10 02 Jan 2017

All three of my machines on manual trigger start.

  Govan1x 20:21 02 Jan 2017

Ok thanks for that I must have changed mine to automatic then.

  bumpkin 20:46 02 Jan 2017

Thanks rdave, it was disabled. Now appears to be working but most likely take several hours. I will post back tomorrow.

  bumpkin 11:49 03 Jan 2017

That seems to have worked, thanks to all. I shall be more careful in future:-)

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Moto G6 Play Review: First Look

The best smart speaker: Apple HomePod vs Google Home vs Amazon Echo

Augmentation du tabac : les meilleures applications pour arrĂȘter de fumer