Windows 10 keeps you signed-in?

  wiganken2 10:12 17 Jan 2019
Answered

I have only had my Windows 10 laptop since November and I have recently noticed the following odd (to me) behaviour - That Windows 10 keeps you signed-in. The OS is Windows 10 Home 64-bit set up as Local Account.

If a user does not sign-out: 1. Sign-in as ‘Visitor’ and then shut down without signing out. 2. Switch back on and sign-in as ‘Another User’ then shut down again. In this case an alert that other people are still signed-in and may lose work will appear.

If a user Signes-out: 3. Sign-in as ‘Visitor’ and sign-out before shutting down. 4. Switch back on and sign-in as ‘Another User’ then shut down again. In this case no alerts appear but it is now ‘Another User’ who remains signed-in because they did not sign out before shutting down.

The above does not happen in Windows 8.1 which signs you out when you shut down the PC. It is clear that Windows 10 keeps you signed-in until you sign out manually. Is this a quirk or setting on my Windows 10 Home machine or is it how W10 works?

  wee eddie 10:43 17 Jan 2019

It's all down to how you/they have setup the Settings

  wiganken2 16:55 17 Jan 2019

If it is a W10 setting then what am I looking for and where will I find it? I have looked for settings such as “Sign user out when user shuts down computer” but cannot find any.

I have seen a couple of sources that state that clicking ‘Start’ then ‘Shut-down’ is really hibernating and that W10 logs the user off before creating the hibernate file but in my case it is not signing a user out first. They are still signed-in when computer is next used.

I have set-up my laptop so that closing the lid causes the machine to ‘Shut Down’ and this ‘Shut Down’ does sign the user out so it behaves differently to ‘Start/Shutdown’ which does not sign the user out.

OK, closing the lid to shut down is a practical work-around but it would be nice if Start/Shutdown behaved the same way.

Any ideas how to make my W10 laptop sign people out when they select Start / Shutdown?

  Bris 17:31 17 Jan 2019

Some have reported that this started with the Creators update but whether it was deliberate or a bug is open to conjecture.

It seems to revolve around fast startup which is a feature of W10 that saves the OS kernal to the hyberfil.sys file similar to hibernate but a shorter version, the reason for this is so that the PC starts faster. With fast startup enabled (the default), when you shutdown it should log out all users regardless but this does not now seem to happen but it is unsure whether this was deliberate or not.

Two things to try. The first is to hold down the shift key when pressing shutdown which will force a shutdown and bypass fast startup or secondly turn off fast startup. Either way it will slow down startup, so up to you.

  wiganken2 09:39 18 Jan 2019

I tried switching Fast Start-up Off and it made no difference except to extend the boot time. So Fast Start-up is not the issue. It may be a W10 feature since Microsoft (MS) want to keep you signed-in to your account in order to spy using telemetry but in my case I set up my laptop to use a Local account. Incidentally my OS is Windows 10 Home 64-bit, v 1803, Build 17134.523 so I am still waiting for the October 2018 update which may fix the issue (or not). Of course it could be a bug which MS will fix. Any thoughts?

  Bris 10:47 18 Jan 2019

I have a similar setup to you i.e. use a local logon and dont get this problem but after some research this "feature" aka bug affects only some computers and only after updates.

Here are some ideas... click here.

  wiganken2 13:04 18 Jan 2019

Thanks, I'll look into it some more.

  wiganken2 18:49 18 Jan 2019

In order to bypass this Windows 10 problem/bug can anyone tell me if it is possible to put a batch file on each user’s desktop which will sign-out the current user first then continue to Shut down the computer after sign-out is complete? If so then can you tell me the script please so that I can write the file? Thanks.

  wiganken2 18:28 19 Jan 2019

FYI - Solved by forcing W10 to use "Shutdown.exe" command with switches as follows: -

Created a shortcut on desktop with "%windir%\system32\shutdown.exe -s -f -t 00" (without quotes) instruction and called it 'Shutdown'.

Double clicking on this shortcut signs user out before shutting down. Sorted.

This works differently to the Start/Shutdown command. Credit to "CountMike" on tenforums: - url="[click here shortcut can't use F4 - Windows 10 Forums[/url] .

  wiganken2 12:09 20 Jan 2019
Answer

Update FYI: - For safety I have deleted the -f switch and the shortcut stills works fine.

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Samsung Galaxy Tab S5e Release Date, Price & Spec

Robert Hunter talks animating his magical storybook style for a spaced out music video

Best iPhone & iPad games 2019

Samsung Galaxy X : date de sortie, prix et fiche technique