Windows 10 does not use secdrv.sys

  crt86t 11:54 14 Dec 2015
Locked

I have just purchased a new PC which came with windows 10. I now find that my Flight Simulator (boxed set) of Just Flight scenery will not load due to secdrv.sys not being available in W10. I have hundreds of pounds invested in this and I am told that I will now have to buy all new scenery. What are MS doing about this? I cannot go back to other earlier Windows versions because my old PC died.

  chezmichdup 14:16 15 Dec 2015

One possible way to bypass the problem would be to load and install VirtualBox 5.0.10 from Oracle (it's free). Create a Virtual machine and install XP SP3 (or whatever version of Windows up to 8.1). Make sure that the "direct mode"checkbox of the optical drive of the virtual machine is checked for passthrough. This is done by cliking on Machine - Configuration - Storage and selecting the virtual CD/DVD drive. Note that for Windows 7 and 8.1 you'll have to issue the "sc config secdrv ... " or "sc start secdrv" command. Refer to "click here

  Fruit Bat /\0/\ 18:52 15 Dec 2015

A work round for windows 10

click here

  chezmichdup 19:16 15 Dec 2015

Unfortunately the workaround doesn't seem to work anymore. Refer to click here and the comment of WMCOLE on november 16th

  crt86t 09:17 16 Dec 2015

Understand! Been there seen all those complaints already. Just wondered if any other guru had found a workaround? I.ve tried loading the CD into a file on the PC and running it from there (no joy). I've tried copying a Windows 7 secdrv.sys from another PC into C:/Windows/Windows32/drivers (no joy but it loads a bit further and then throws up with a "can't load FSTYPE.dll" message). FSTYPE.dll is also on the CD and I can't find a further solution to this.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Amazon slashes Echo Dot price to just £24.99 to kick off Black Friday

The 51 Best Free Typefaces Every Designer Should Have

Mac mini 2018 review

Les meilleurs écouteurs et casques audio (2018)