Win 7 System Restore Problem

  rawprawn 10:44 22 Jan 2010

After trying out Comodo Time Machine, I now find SR is not working properly.(Uninstalled CMT)
I can make manual restore points, and it makes a restore point after a windows update, but it doesn't make system check points.
I have run sfc /scannow, with no problems found.
I have tried to delete all previoue restore points but it leaves 4 old ones, and if I try to use one of those I get the message Element not found Error 0x80070490.
If I go to Task Scheduler in services it says it's running on Auto, but if I click on it I get
"Selected Task No Longer Exists "(0)"
I am totally stuck any help gratefully received.

  rawprawn 11:30 22 Jan 2010

I have just tried test system restore from a manual restore point, and it worked no problem.
Has anybody any ideas, or even as to how I can delete the old 4 remaining restore points showing. I assume it can be done in the registry, but I don't know how.

  rawprawn 13:25 22 Jan 2010

The problem appears to be with Task Scheduler, if I open Services and then go to Task Scheduler it shows as running on Auto, but if I look in Properties everything is greyed out and I cannot reset it.

  rawprawn 15:25 22 Jan 2010

I have just tried a "Repair Install" (Win 7 Upgrade, but it was not successful.
I am really struggling now.

  john bunyan 16:10 22 Jan 2010

I have only been with W7 for a few weeks. As at today there are only two restore points - afrtr "critical updates" on 20th and 22nd Jan. I think W7 only keeps the latest - not like XP where you could go back many days.

  john bunyan 16:12 22 Jan 2010

Also see here:
click here

  rawprawn 16:52 22 Jan 2010

Hi john bunyan, thanks for coming back . I have put Volume Shadow Copy Service on Auto, I then turned System Restore Off and rebooted, then turned it back on and rebooted. It didn't make a restore point but it does manually.
Each time I try to configure it I get a message that it can't because the file already exists Error 0x800700B7.
I am trying to work my way through all the suggestion gained from your link.

  rawprawn 17:17 22 Jan 2010

" I think W7 only keeps the latest "

there is a box to tick "Show More Restore Points"
Try that.

  john bunyan 19:01 22 Jan 2010

Yes, when I tick that box I just got the 20th Jan restore point after a critical update - only the 22nd one showed in the normal box. No earlier restore points were shown. As long as it works, so be it but I would prefer the option of going back further - maybe others will comment. JB.

  rawprawn 19:14 22 Jan 2010

Have you looked in "Configure" to see if there is enough space allocated? You need it set about 11/12GB

  john bunyan 19:33 22 Jan 2010

Thanks again. It was set at 1.2 gig - have increased it to 11 gig - will watch and wait.JB

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?