Win 10 PC not recognising IDE enclosure

  haley6000 10:40 14 Aug 2018

Hi everyone

I am not a tech expert and a very basic computer user. What I’m trying to do is open files I had on two old hard drives which were once part of my old laptop and old pc.

I use a PC with Win 10. I had two old hard drives from old computers and laptops with data. One needed a SATA enclosure to read it and this I achieved successfully. I can read the files and copy them. They show in Win Explorer.

The other drive, from an old Toshiba Laptop required an IDE drive. I bought one from PC world (Dynamode 2.5” External IDE Hard Disk Enclosure). This I connected to my PC, but it doesn’t show in Win Explorer. The IDE drive does show in ‘disk management’ and it connects fine because I can eject it normally from the ‘eject software’ button when you want to close a program.

Now I tried to find online info on how to view the disk and I found advice telling me to check the ‘disk management’ and open it from there. I can see the ide enclosure but I cannot open it. The files show as RAW and win 10 tells me they need to be formatted. Of course I did not format as there is data on it.

I have tried Recuva recovery, which doesn’t see the drive. I tried another one, which was able to recover but I couldn’t do anything as it was a paid service., So I uninstalled it and tried Stellar Windows Recovery Tool, which also could not find the IDE enclosure.

I want to see if I can get my PC to open the IDE enclosure without formatting the drive and without a paid recovery service.

Can anyone tell me what I need to do? I’m sure it is a simple setting change. My computer recognised the SATA drive but why not the IDE drive? Admittedly it was older, and it had an earlier version of Windows.

Thank you in advance for tips. when responding please lay out clear instructions as i don't understand tech talk. Im a total newbie. Many thanks.

  Fruit Bat /\0/\ 17:54 14 Aug 2018
  1. check the jumper on the back of the drive is set in the master position

  2. EAsus data recovery is free click here instructions click here

  haley6000 18:16 14 Aug 2018

I tired EAsus some time ago on another issue (before i bought the enclosures) and although it scans and finds data it is not free to do anything with it. Have you used it recently?

There is nothing on the back of the drive. Literally there is just a cover, that can come off. Is the 'jumper' underneath the cover? what does it look like? I noticed that it had copper pins which fitted in the hard drive, and it had 2 or 4 separate pins which did not. On the front of the drive there is a blue light indicator which lights up when it is being used, and a slot for the USB. The only other things i see are two holes on the sides at the bottom, ( I did not attach the two tiny screws which came with the drive) and it also has two holes on the side at the top which seem to be closed.

  haley6000 18:24 14 Aug 2018

This is the Ide enclosure i'm using DYNAMODE 2.5" USB 2.0 IDE Hard Drive Enclosure click here remember one problem I had with the SATA drive, was that i had to claim ownership of the disk. I did this by using a software called 'takeownershipex.exe'

But the problem i'm having with this drive is that the data is RAW and some of the recovery software i tried (but abandoned) wanted to format the disk.

I

  alanrwood 18:26 14 Aug 2018

The jumpers that you mention probably need setting up as a master disk. Try looking at the hard drive label where they usually show the various jumper setting for Master/Slave etc.

  haley6000 18:40 14 Aug 2018

to alanrwood

I just took the disk out of the enclosure, and there is a label on the old hard drive which says 'New Master). The back is covered with labels with figures. Disk Drive DC+5V HDD2165 and Toshiba Corporation and other stuff.

Where exactly is this is driver thing? is it on the old hard drive or on the part of the enclosure which has a gree part which connects to the pins? I've taken the drive oout of the enclosure, but it is still connected to part of the enclosure in which the USB fits. I'm assuming i can use the drive like this and it it would work although obviously its not ideal for a long term situation.

  lotvic 19:08 14 Aug 2018

  haley6000 08:54 15 Aug 2018

Iotvic

Thanks, but I don't see that at the back of the drive. Also am i supposed to move somnthing? i'm totally tech illiterate.

Anyway, I tried to do a recovery with Easus as the first reply above suggested andEasus does do a scan, and found files although I didn't recover any. Some of them under 'preview' showed gobbled up text.

I'd still like to be able to open the disk and read it without a recovery if possible.

Any tips anyone? thanks in advance.

  Fruit Bat /\0/\ 13:08 15 Aug 2018

right click start - command prompt or powershell (admin)

type chkdsk /f/r f:

where f is the drive letter of the toshiba drive - change f to whatever your drive letter happens to be.

press enter and let the drive scan, it could take awhile - on completetion type exit tp close the command prompt window.

hoefully that will repair the file system and the drive should then appear in explorer.

  haley6000 16:09 15 Aug 2018

Hi Fruitbat, thanks I tried that, after assigning a drive letter in disk management. The message says: CHKDSK is now available for RAW drives.

If i try to open the drive f in Windows (it now shows in windows explorer) it says it needs formatting. I can't format because there is data on it. Catch 22

  haley6000 16:11 15 Aug 2018

sorry, i made a typo above, I should have written:

CHKDSK is not available for RAW drives

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

Google Home Hub review

Print legends Dan Mumford and Supermundane on making the leap from 2D to AR

How to watch Apple’s October 2018 iPad launch

OnePlus 6T : date de sortie, prix et autres rumeurs