Weird Write Protected USB Drive

  The Guy WhoTalks About Beer 09:04 25 Sep 2015
Locked

Hello, So I've had an Imation 8GB USB drive probably around 5-6 months, so fairly new. But one day my USB drive just doesn't want to receive SOME files, especially big files (I'm talking about 2GB+). The files I tried to copy were movie files and game files, it just suddenly stopped copying them. I tried formatting my USB in different ways. I also tried using the cmd trick, It said that it is not actually write-protected, it's just every time I try to copy certain files it just turns into a useless USB drive. I can still copy word documents, presentations, etc. It's like locked whenever I try to copy things besides word documents and excel and those basic things. Oh! and I also forgot to mention, there is no write-protection switch anywhere on the USB drive. Any help? Thanks

  xania 16:38 25 Sep 2015

If you can copy any files, you can rule out anything to do with the hardware - the only thing might be that some of the files may have a copyright protection which would stop you taking copies. Also 2 Gb is pretty large to copy onto an 8Gb media. But I'm also wondering if your media is not able to store all 8 Gb. I suggest you test it with h2testw from

click here

  Fruit Bat /\0/\ 17:04 25 Sep 2015

If its formatted to fat32 then max size of file is 4G click here most TVs / DVD / PVR players won't see a NTFS drive you my need to format it in the machine concerned. Then windows won't see it without third party software.

has

  mole1944 18:47 25 Sep 2015

Try this scroll down to the bottom to find the download link,it completely formats your drive/card and sets it back to factory fresh.click here

  The Guy WhoTalks About Beer 22:53 25 Sep 2015

Mole1944, I've already tried that method, sadly it did not work :(. Fruit Bat /\0/\, A forum in another website told me to format my USB drive to exfat instead of fat32, I did and it still doing the same thing. Toejams, it's using exfat when I last formatted it. Xania, my friends have them in their USB and they seem to be doing fine with them, so I guess it's my USB. I tried doing your method with h2testw and it said this

Error writing file 'E:\2.h2w', offset 0x28700000. It is still possible to verify the test data written up to this point. (The media is write protected. Code 19) Warning: Only 7529 of 7634 MByte tested. Writing speed: 9.92 MByte/s H2testw v1.4

So yeah! I don't know what that means but it's saying something about media is write-protected code 19 or something but, it still doesn't work.

I might just get a new USB for personal use and this one for work purposes. Anyways, thanks for your guys's help!

  Fruit Bat /\0/\ 23:58 25 Sep 2015
  1. Run DiskPart

  2. List and select the disk that needs to be made available.

    LIST DISK

    SELECT DISK (disk no.)

  3. If the disk is offline, bring it online by running ONLINE DISK

  4. View the attributes by running DETAIL DISK

  5. run ATTRIBUTE DISK CLEAR READONLY -- To clear the read only flag
  6. Exit DiskPart
  The Guy WhoTalks About Beer 06:20 26 Sep 2015

Fruit Bat /\0/\, I've already mentioned it and I'm going to mention it again, I've tried that trick, but sadly it doesn't say its write-protected, It's only write-protected when I try to copy mentioned files.

  robin_x 09:14 26 Sep 2015

I wonder if DISKPART CLEAN etc would work (if it's a corrupted partition table)

or

You could try Resizing the partition so as not to use the last 105MB, where it finds a problem.

Right click the drive partition space with Minitool Partition Wizard Free, Resize and set at 7528MB.

Then click Apply.

or

Throw it away and replace with 16GB or more (unless pennies are tight)

  The Guy WhoTalks About Beer 09:24 26 Sep 2015

Robin_x, thanks for the help, but I might just use this "corrupted" one for copying documents and stuff, since that's the only thing it can do :P. And I might just buy a new USB drive for my personal use or even an external hard drive. Thanks for all your guys' help! :) Appreciated it!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

EE 5G review: How fast is 5G in the UK?

How to Brand a Film Festival, Saul Bass style

How to install the iOS 13 beta on iPhone or iPad

Les meilleurs ├ętuis et housses pour Kindle (2019)