Vista reinstall = Games no longer installing?

  fbadt 13:51 03 Jun 2009

Hi all,
Wondered if anyone could help me with a vista problem. Recently my Vista 32-bit corrupted & I had to do a complete harddrive wipe & reinstall for vista and all the drivers, including downloading the latest driver from ATI for my card (I have a 512MB ATI Radeon 4850 Graphics card). When it came to reinstalling my games several no longer install. For example MOH Airborne shows the install screen, asks for the reg.key then install screen starts but then just disappears as if it never happened. next time it asks for the reg.key as if I didn't the first time. other games install but then just hang while trying to start and some come up with Runtime C+++ error or something? Yet other much older games which had never run in the original (Dell installed) Vista install such as Messiah and Star Trek Elite Force run fine. It's not all recent games that aren't loading, just a few that were perfectly fine first time around. Anyone have clue as to why that would happen? Anyone have any idea what's going on/what I'm doing wrong?

  Kevscar1 18:41 03 Jun 2009

Have you done the Vista updates

  fbadt 08:08 04 Jun 2009

Hi Kevscar
yes, it's up todate, I hoped the recent Service Pack would help but nothing, would there be any sort of conflict between my ATI card and what the games require? Perhaps when I updated the driver after the reinstall? what really confused me was after the reinstall/update the older games started running, games like SW Jedi Academy and ST Elite Force would load, run through the menu and first cut-screen, then crash/close down as soon as you were into the game, now they run fine? none of the discs look damaged.

  Kevscar1 14:53 04 Jun 2009

Don't know if it will work for you but I've had a couple that would only work if I installed them as Administrator.
Might be worth a try.

  mrwoowoo 18:15 04 Jun 2009

Or try turning off the UAC while you install and try to play them.

  Kevscar1 18:35 04 Jun 2009

Found this on a forum

If I remember rightly I had the same problem, think it was due to the display adapter.

click here

click here

click here

click here

click here

click here

  fbadt 08:20 05 Jun 2009

awesome I'll check out those links and let you know, it's so odd the older games suddenly running.
to answer the other questions, I have the only login/acount so I should be the administrator shouldn't I, do I need to change that somewhere? I tried right-clicking on the install and running as admin but that didn't make any difference. I have turned off UAC although I also tried to install Dreamfall and the StarForce 'thing' was still blocked and everytime I start up the PC it warns me StarForce is blocked even tho I uninstalled Dreamfall in the end, does that mean UAC is still running somewhere?
sorry for the ramble, I'm not too up on the inner workings of windows/vista.
thanks again for your help

  Kevscar1 18:11 05 Jun 2009

Starforce might be your problem. I had trouble with it leaving drivers behind. Go here to sort them out.

click here

  mrwoowoo 13:52 08 Jun 2009

Vista sometimes has a problem with auto install.
When you insert a disc,shut down the install programme page that appears.
Then go to computer and D drive(if that's the drive with your disc in) and explore the disc that you are trying to install.
Find the 'set up' file and double click on it and follow the instructions as usual
Hopefully it will install ok from there.

  fbadt 18:05 08 Jun 2009

thanks for both those suggestions but neither worked, what a jip. Least i got rid of the StarForce drivers, it gets to windows installer then goes off, for the breifest second I see a second window which I think says Ageia Physx - does that mean anything? If that's an NVidia driver could it be conflicting with my ATI? even if it ran before? the game specs says my card is okay, and it did install before, was I just lucky? another odd one is No one Lives Forever 2, I don't get any sound on that, soundtrack but no effects, tried the various changes the Read Me suggests, but nothing there either. it's all so odd!
thanks again Kevscar/mrwoowoo

  mrwoowoo 19:38 08 Jun 2009

You are quite right.
The Ageia Physx is a graphical accelerator for Nvidia cards only.
You should get the choice not to install Ageia Physx when you try to install the game.
If a game developer has created a game that requires PhysX to be run on the video card they should provide a way to disable it or stop it running.
Did you have an Nvidia card when the games ran properly?
Did you try turning of your user account control?
As an aside.My sons pc has an ATI card and they often can't play games that i can.
Perhaps it is the Ageia Physx thing.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator of witty, relatable Instagram comics Julia Bernhard touches on our humble moments

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?