USB Keyboard problem....

  bigrad 22:28 13 Jun 2011

My Vista laptop keyboard has become very tatty over the years so I plugged in a USB keyboard so I could actually see which key was which. The USB keyboard works fine but the trouble is that now the laptop keys themselves just produce completely wrong characters when you hit them. It makes no difference whether the USB keyboard is plugged in or not. I have tried restoring but it refuses to co operate and simply reports an "Unspecified error" and changes nothing. Is there an obvious answer to this? I was planning to un-install the keyboard driver to see what happened, but I cant find it. Any help would be appreciated. Cheers.

  bigrad 23:14 13 Jun 2011

Well I tried last good config - no effect

Running in safe mode - no effect

F12 / F8 work as advertised

No CDs of any sort supplied with laptop, so haven't tried that. No idea what Puppy Linux is. Sorry.

Just seems so weird that what amounts to a USB peripheral would knock over the inbuilt keyboard.

  bigrad 23:22 13 Jun 2011

I have just checked device manager and it reports all keyboard devices working properly - which they're not obviously!

  chub_tor 13:00 14 Jun 2011

If you have found the keyboard in Device Manager then you can right click it, unistall, delete the driver and let Windows find it again by going to New Hardware Search or re-boot.

  bigrad 17:19 14 Jun 2011

I did think about deleting and reinstalling the driver but I was concerned that if it was reported as working OK I might make things worse if there was a deeper problem by deleting it and then it fail to reinstall itself. In the end I booted up in F8 and did a system restore from the checkpoint the day before using the offered recovery menu, which worked and put everything back as it should be. I don't know why this worked when a system restore from within a fully loaded Windows didn't, nor do I know what caused the actual problem to occur in the 1st place,apart from the fact that it was clearly related to using a USB keyboard, but there you go. Thanks for everyone's input.

  chub_tor 09:00 15 Jun 2011

Glad that you got it working again and thanks for posting the fix.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Quelle est la meilleure application de podcast pour Android (2018) ?