USB Flash Drive Not Showing In My Computer

  si67 14:48 13 Aug 2007


just taken receipt of a PC with Vista Home Edition installed. All is well until I try to put in my Datawrite 1MB USB Flash Drive. Absolutely nothing shows in My Computer. I've tried all 7 USB ports but nothing shows. The ports are working as I've tried them with other devices.

The USB Flash Drive worked perfectly in XP. As the USB Flash Drive is Plug And Play no drivers were supplied with it. Visiting the Datawrite website proved unsuccessful as they dont supply drivers.

Anyone have any suggestions?


  computech 15:27 13 Aug 2007

could it be a usb 2 computability problem, did the device work on the computer before you put vista on their?

  si67 15:33 13 Aug 2007

The device works perfectly in my XP computer. This new PC has Vista pre-installed.

  PP321 18:37 13 Aug 2007

i posted this elsewhere, it may help you

Try this

Plug it into the troublesome computer, wait 20 seconds or so, then right click on my computer , then click manage, then click disk management , right mouse click on it if its there, choose "change drive letter and paths" then select a letter from "N" onwards then click change, then ok.

If the autorun doesnt appear, unplug and replug the device.

  skidzy 18:42 13 Aug 2007

is the drive listed in Disc management ?

Right click computer / manage / Disc management

  skidzy 18:43 13 Aug 2007

Sorry about that,forgot to refresh Doh !
Didnt mean to echo your post.

  si67 19:59 13 Aug 2007

Hi guys. Tried lookin for it in Disc Management but it doesnt show. Plugged in USB MP3 player and it does show. Then tried Flash Drive in my XP Pro PC and it works. Very confused.


  skidzy 20:25 13 Aug 2007

Is there data on the flash drive ?

I would suggest saving the data on the xp machine and then format the flash drive and try in the vista machine again.

Just a bit of a guess now:
Download netframework 2.0 install and reboot.Assuming you do not have this installed click here

Then try the flash drive again.

You could even try version 3.0,though we are led to believe version 3.0 has versions 1.1 / 2.0 / incorporated into version 3.0 click here

  si67 20:37 13 Aug 2007

Hi Skidzy

there is over 700MB of data on the flash drive.

If I save data to my XP machine how do I format it in the Vista or XP machine?

I have Netframework 2 already installed on the Vista PC.

Your continued help is really appreciated.


  skidzy 20:46 13 Aug 2007

Firstly try formatting the drive in xp,basically giving it a fresh start.
Dont forget to save the data first !!!

Though a quick thought,check the Vista bios for anything relating to usb flashdrives..make sure it says enabled,f10 to save and exit,reboot and try the flashdrive again.

Sorry about the so many things,but these are the basic steps to try first.

Just out of curosity,when the flash drive is plugged in,does it show in device manager ? i would not think so at this stage.

  si67 21:53 13 Aug 2007

Hi Skidzy

I have checked the BIOS and nothin shows relatin to USB flashdrives.

When the flash drive is plugged in it does show in Device manager. Vista asks me to install drivers, but as previously mentioned the Datawrite Flash Drive doesnt come with drivers as it's 'Plug & Play'.



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

WWDC history: Apple's product launches since 2005

Comment importer des contacts d’un iPhone à un autre iPhone ?