TWAIN drivers for canon scanners

  Lammy Pie 21:25 22 Sep 2007

Another frustrated Vista user here... I have a Canon Scanner, CanoScan N124OU. I cannot load the drivers from the disc I have as I am being told I do not have the TWAIN drivers and need to load those first. Can anyone help? This is a new one on me. Like many of you out there I am now thinking I have to go and buy a new Vista compatible scanner!

  Probabilitydrive 22:37 22 Sep 2007

Did you try uninstalling and reinstalling using the Vista drivers from the Canon website?
click here

  Ashrich 20:15 23 Sep 2007

If they've got a driver for my old N670u they must have a Vista driver for the newer N1240u , have a look at their web site as Probabilitydrive suggests .


  phoenix198 22:08 23 Sep 2007

There are Vista 32-bit drivers for the Canoscan N1240U on the Australian Canon website - version - together with a Vista compatible version of the Canon Toolbox utility.

I can't direct link to them but try Googling for "Canoscan N1240U Vista drivers"

  skidzy 22:58 23 Sep 2007
  skidzy 23:01 23 Sep 2007

click here

Then Setup Vista,agree to the disclaimer and follow the prompts.

  Ashrich 13:05 24 Sep 2007

Funnily enough , I got my Vista drivers from the Aussie site .....and they are also


  Lammy Pie 13:25 24 Sep 2007

I have tried to load from the Australian site as suggested. It goes through the process fine until the end when I get a message to say it may not have been uploaded correctly. I still can't get my scanner to work! Is the TWAIN element seperate to the main drivers? Thanks for all the advice!

  Lammy Pie 18:36 24 Sep 2007

I have talked to Canon and they had me load two sets from their web site, it still doesn't work and doesn't even see the scanner when I look for it thorugh Windows Accessories. Thinking of buying an Epson now.

  Vaio-fan 14:07 07 Jan 2008

Hey Lammy Pie, do you still have a problem with Canoscan N124ou and Vista?
Let me know, I was in exactly the same situationj as yours and I solved the problem.

  DerekGCWhite 22:48 17 Jan 2008

I have just found this link and I am having exactly the similar problem, Vaio-fan you said you have the answer, would you share that with me please?



This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Meilleurs drones (2018)