Trust Wireless Mouse not working

  interzone55 21:27 10 Jul 2007

I've read about this in several forums, and none of the solutions work...

Suddenly yesterday my mouse stopped working, sometimes it appears as an unknown device attached to a USB port, sometimes it can't be found.

I tried re-install it, but vista can't find the driver & I don't have a disk as Trust don't supply them as Vista is supposed to have drivers already.

I read about deleting INFACACHE.1 from windows\inf and reinstalling another device, then searching for the mouse, but this doesn't work.

I've also read that PS2 mice do not have this problem, but this is a brand new laptop with no PS2 ports

Anyone got any other ideas?

  anskyber 21:38 10 Jul 2007

I'm to embarrassed to ask, have you tried new batteries (!)

  interzone55 08:36 11 Jul 2007

It's not batteries, i've tried several mice, wired & wireless.

This seems a common problem with Vista.

My experience is exactly the same as this guys click here

  interzone55 08:37 11 Jul 2007


but the solution mentioned at the bottom won't work as I don't have CHIC drivers installed.

  interzone55 19:58 11 Jul 2007


I've now just installed a brand new Microsoft Wireless Optical Mouse 3000, which the box claims is "Certified for Windows Vista".

After installing the software, plugging in the mouse and rebooting the mouse worked for about 30 seconds until a window popped up claiming that windows could not find a driver for your device

Back to square one. I think square two is installing Ubuntu... wouldn't that be fun, removing Windows and installing Linux because windows won't work with a Microsoft Mouse...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)