Trouble installing downloads & updates - poss registry issues?

  RayKelly 17:55 19 Dec 2014

I have a number of problems which I suspect have a common cause. I'll list them as briefly as I can and try not to lose my rag as this is simply driving me nuts now and I feel like crying.

  1. Adobe Acrobat - Error 1406 when installing (cannot write value, make sure you have admin etc)
  2. Citrix receiver - gives an error "cannot write value to key [insert key here]. Make sure you have admin privileges etc
  3. Windows update for Office 2007 - KB2817330, KB2850022, KB2878233, KB2880508, KB2881069, KB2984942, KB2596857, KB2825644, KB2817565, KB2920793, KB2863811, KB2597972). Error 57E.

In all cases it seems at first that these are permission issues. However I am also getting the same problem when I am logged in run as administrator. I've tried changing the registry keys to allow access to everyone, I've run countless MS Fixits which have reported no problems, turned off antivirus, antimalware etc.

If anyone can please help with this - I really need Citrix Receiver so I can work from home more so I can look after a sick relative.

  Fruit Bat /\0/\ 19:48 19 Dec 2014

Allowed full control?

  Secret-Squirrel 20:02 19 Dec 2014

Ray, so that I can give you specific advice, which version of Windows are you running?

  RayKelly 20:46 19 Dec 2014

I'm running Windows 7. I've done full control - at least I think I have - I'm beginning to think I'm living on another planet at the moment!

  rdave13 08:37 20 Dec 2014

Have you tried any restore points to before this problem? It looks as your registry is messed up.

  Secret-Squirrel 09:15 20 Dec 2014

Thanks Ray.

Here's a simple tool that will automatically reset all the Registry permissions giving the Administrators' group full control. It's a lot quicker, easier and safer than changing them manually with scripts and Command Prompt. Hopefully it'll fix your problems.

To be on the safe side, before you proceed, set a Windows System Restore point just in case things don't work out as expected and you need to restore your computer back to how it was before you ran that tool. Have a read here if you're not familiar with it.

  RayKelly 11:26 20 Dec 2014

Hi Squirrel, have followed the instructions on that code and still no joy. Getting exactly the same errors.

I think I'm just going to back up my data on cloud and do a factory reset on my laptop to see if that fixes anything.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review: Hands-on

How to add texture to hand-drawn artworks

Best free iPad apps 2018

Comment créer un compte PayPal pour payer en ligne ?