Surface Pro 4 Can't boot from Internal Storage

  Jacoob 11:49 01 Sep 2018
Locked

Hello

Couple moths ago i brooke my Surface Pro 3 so i removed hard drive and i kept it. Recently i boutgh Surface Pro 4 and connected old hard drive from SP3 by mSATA to USB adaptor. I successfully booted new Surface Pro 4 with my old SSD but now I have problem with booting it from internal storage. It keep booting into UEFI. I can only boot him to old SSD by USB

I've tried this click here but when i boot Surface from USB fixing Windows doesnt work and when i go to install I keep getting this error

Then i tried this click here but it also didnt work. When I go to SYstem Image Recovery i get this

Is there anything else I can try to fix this?? 1]: [click here 2]: [click here

  Jacoob 13:40 01 Sep 2018

Boot order is fine. Like in this picture click here Surface tries to boot from internal storage but when it fails it boot from SSD connected to USB. When i remove it from USB it just boot to UEFI.

  Jacoob 16:32 01 Sep 2018

Yes it was running before that. I bought it used and its out of warranty i made a topic on Microsoft website but nothing worked...

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Fold review: Hands-on

Best Wacom deals for Easter

iMac 21.5in (2019) review

Comment faire pivoter une vidéo ?