Setting up HomeGroup on two Win7 computers

  cagey 22:05 27 Feb 2013

I'm unsuccessful in setting up a Homegroup on my Laptop running Win7 64bit and my PC also running Win7 64bit. After trying various suggestions, I notice that the IPv4 addresses are different (Laptop, PC Could this be the cause of my failure to set up the Homegroup and if so how can I remedy the problem?

  difarn 08:11 28 Feb 2013

Both pc's need their own IP addresses. Have you trie running this troubleshooter?

Sometimes this works..

Shut down both computers; Unplug the router; disconnect the desktop's ethernet cable if connected this way; Plug in router; Boot computers.

  Chronos the 2nd 08:33 28 Feb 2013

Useful to know what you have tried before to sort this problem. The different IP addresses is what it should be.

I have a small network and the great thing about Windows 7 is being able to add a PC to the network as I did yesterday. All that was needed was to click on home network on the PC I want to join the Homegroup and follow the on-screen instructions and add the password which you will get from the original PC.

  cagey 11:51 28 Feb 2013

Hi lads, thanks for replies. Both computers were both wireless. I disabled the wireless facility and connected both via lan cables and successfully set up my Homegroup. However, when I disconnected the cables and enabled wireless, the Homegroup appeared but I couldn't open the libraries. I have noticed in some troubleshooting, it says that IPv6 must be enabled; I can do this on the PC, but when I tick the box to enable it on my laptop and check Properties, a message comes up "In order to configure TCP/IP, you must install and enable a network adapter card". Could this be the cause of not being able to open libraries and how do I rectify it? Any help is much appreciated.

  cagey 16:49 28 Feb 2013

I think I have solved my problem. I found this solution on another forum.

"Then i went to check my kaspersky internet security 2010 firewall settings for both PC and laptop; under the Firewall settings -> Network (Tab), PC shows the network connection to the modem STATUS is "Local Network" and the laptop shows "Public Network", SO I CHANGED THE LAPTOP network connection from "Public Network" to "Local Network" AND IT WORKS!"

I am using Kaspersky 2012 on both computers, so I carried this out on both computers and it appears to be ok. I'll keep my fingers crossed that problem is now solved

  difarn 16:54 28 Feb 2013

I assumed that the troubleshooter link given earlier explained this, obviousl not. Glad you have resolved the problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)