SD card not recognised reliably

  keith mac 05:04 03 Aug 2009

Vista laptop, integrated card reader.

I use a 128mB SD card in my camera. After taking photos I remove the card and use the card reader on my computer to transfer images using Nikon software. The software has worked faultlessly for 5 years.

Recently I did the above, pulled out the card, but then reinserted it to check something only to find it wasn't recognised and didn't show in 'My Computer' as it usually does. Restarting the computer restores the recognition process but only once as above. A System Restore didn't change anything...

I have read that removing through the 'Safely Remove Hardware' utility uninstalls the reader software so I don't do that.

Is this a USB issue? Or is there a Vista issue with SD cards? Or might there be a rogue entry in the Registry?

Any suggestions, any fixes, whatever?

  mooly 07:18 03 Aug 2009

The "safely remove hardware" is something you should use, it doesn't uninstall anything, it simply checks and if neccessary stops any read/write cycles to the card allowing it to be removed. Removing any USB device like a card when it is actually being written to is asking for trouble.
Does Vista's "auto play" detect the card when you insert it. You say it's worked for 5 years ? What has ? Vista hasn't been around that long, do you mean your Nikon software... that's a diferent issue.
Have you tried another card, or reformatted this one and tried again.

  keith mac 14:01 03 Aug 2009

I never remove the card when it's being read or written to.

I've used both ways of removing the card in the past without problems - using 'Safely Remove Hardware' and without it. I'm used to using the utility for spinning drives but there's nothing moving in solid state card as you already know. I'll try both ways again for comparison - it's a while since I tried 'Safely R.H.'

Yes Autoplay detects the card first time but not subsequently without restarting the computer....

I've used the Nikon software for 5 years, previously on an XP equipped laptop but that didn't have a card reader and I just used a USB cable. The software was written for XP compatibility but has been fine in Vista since I bought this new machine. I could look again for a Vista version from Nikon I suppose but I think I did that after I got this new computer and it wasn't available at that time. The computer is 2 years old.

I've reformatted the card using the camera. The only other card I have is 2 Gig and the computer is very hit-and-miss at detecting that. Most times it fails but sometimes it will detect it. Again I have read that 2 Gig cards have caused various recognition problems and I gave up trying with it...

Does that give any clues mooly?

  mooly 15:23 03 Aug 2009

Any clues... not really.
If you look in device manager under PCMCIA, that's the card reader. When it's not working, ie you've stuck a card in the slot and nothing happens and the card doesn't show in "computer" have a look as above and see if it's flagged with a yellow triangle (problem) or not. Expand the tab and see if it says "this device is working normally" etc. In fact look as well when it is working, see what it all says.
Question is, is Auto play not working because it thinks there's nothing there (card reader problem) or something else.
Don't think this applies here but anyway,
click here

It's always worth running a Disk Check from <computer> <properties> <Tools> and <error checking> Make sure both boxes are ticked and do a restart to let it commence.
When that's done run from cmd.exe (Type cmd.exe into Vista search box and right click CMD.EXE and run as admin) the sfc file checker that should be able to repair any corrupt files. Nothing lost doing this anyway.
Type exactly sfc /SCANNOW and press enter... allow around 30 minutes plus for it to run and read the report after.

  keith mac 15:32 03 Aug 2009

thanks mooly

I checked the link and - as you thought - it doesn't look relevant but I'll read it again to double-check.

I'll also check through each of the other procedures you've suggested later in the day. I checked device manager yesterday but I'll make doubly sure before moving on.

Looks like I have a bit of work ahead!

thanks for the suggestions - I'll come back to you later..

  keith mac 00:46 08 Aug 2009

I couldn't sort anything. Makes me wonder if it has always happened.

I usually transfer a day's photos at a time so the computer always gets switched off before the next day's transfers.....

Using the 'Safely Remove Hardware' utility didn't have any effect.

I'm going to have a look for a Vista camera driver just in case....

Thanks for your suggestions - I can live with the quirk if I don't get anywhere with a driver.

  keith mac 00:04 09 Aug 2009

A bit more fiddling today and a look-see in Device Manager after reinserting the SD card yielded this:

Code 38: Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory

Searching the MS website I found this:

Updated: August 31, 2007

Applies To: Windows Server 2008

Device Manager displays the following message in the Device Properties dialog box, on the General tab, in the Device Status text box:

Windows cannot load the device driver for this hardware because a previous instance of the device driver is still in memory. (Code 38)

The driver cannot load because a previous instance is still loaded.

Restart the computer.

So there we have the work-around I've been using as the Microsoft solution to the problem - restart the computer!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)