Regcure ?

  EARLR 10:42 15 Nov 2008

Due to the many problems I am having with this machine I Googled the file name that covergirl mentioned; see Memery sticks ?

It recomended Reg cure. When I ran Regcure it came up with well over 200 problems.

I was worred so I didn't alow it to continue.

Has anyone used it?
It looks very aggresive.


  ol blueeyes 10:53 15 Nov 2008

I have used it and to me it seems to imagine problems. Gave up on it some while ago.

  EARLR 13:04 15 Nov 2008

Well I went ahead and bought it (getting furstrated)
Ran it ; PC seems to be faster.
Will keep open for a while.

  Woolwell 13:51 15 Nov 2008

Just a word of caution - some of these registry programs can produce more problems than they solve. You have a new machine on which you seem to have many problems, mainly USB, and by installing Regcure you are open to the manufacturer/retailer now claiming that it is the software that you have installed that is the cause of your problems.

  skidzy 17:05 15 Nov 2008

Problem is;
running multiple tools,they all find something others miss.

For example;
If you run Regcure (this can be aggressive) and then run Ccleaner you will see more entries to be cleaned.

Same goes for running Winaso and Cleanup or Eusing or Registry Mechanic...the list is endless as will be your results.

In my opinion,if you want to pay for a reg cleaner....Registry Mechanic is just about the best around,though Ccleaner would suffice.

Registry Mechanic click here

  EARLR 10:24 17 Nov 2008

Woolwell & skidzy;

I tried it to fix the usbstor problem I have.
It Did not. I have requested a refund.
The problem I have is Plug an Play doesn't work with USB devices (Hubs & External HD's)

I have been told on this forum that :
(%systemroot%/inf\usbstor.inf) is faulty or not there.

Does anyone know how to fix this problem ?


  chub_tor 10:52 17 Nov 2008

You can download it from click here and use Explorer to put it in the Windows inf file.

  EARLR 11:19 17 Nov 2008


I am not sure how to do that.
Detailed instrucions please.

Thanks in advance.


  chub_tor 16:06 17 Nov 2008

Go to the website that I posted and download usbstor.inf to your desktop or to a file that you can remember.

Start/All Programs/Accesories/Windows Explorer will open up Windows so that you can see all your folders. Open up the Windows file, scroll to the inf folder and open it.

Scroll down and look for usbstor, be careful there are several usb files, make sure you get the right one. If it is present then right click on it and rename it to usbstor.old or something similar.

After you have renamed it or if it is not present then go to the downloaded file and click and drag it across to the inf folder.

Reboot and see if you problem has gone away.

  EARLR 17:27 17 Nov 2008

Tried that but the file downloaded is text and drag and drop didn't work.
However the files look the same.
I still dont know where plug & play went.


  Sea Urchin 17:53 17 Nov 2008

You say that drag and drop didn't work, and that the file is text. You shouldn't be opening the file - just drag the icon from the desktop into the inf folder and drop it there as chub_tor describes.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?