Razer devices not being detected

  Azurez 19:17 08 Nov 2015
Locked

My razer devices are not being detected in Razer Synapse. The only device that does show up in device manager is my Razer Blackwidow keyboard, all my mice show up as HID-compliant mouse. My mice seem to work on other pcs so I believe the problem has something to do with my PC. I recently used Driver Booster 3 to see if that could solve it, but no luck yet. Both mice work, but I cant tweak their performance in the Razer synapse program. They also sometimes "malfunction" and have to be unplugged and plugged back in. The sound prompt for plugging a device in starts happening for no reason at other times.

  Azurez 20:34 08 Nov 2015

I seem to have solved it myself. I manually installed the drivers to HID-compliant mouse and used the Synapse file with Device Manager. That seems to have solved the problem. I just hope this stops the randomly disconnecting of these devices.

Mods can delete this thread if they like. Thanks.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Red Dead Online release date and gameplay news

Create a glowing superhero

Mac mini 2018 review

Les meilleures prises CPL