Problem with Lidl "Silvercrest" mouse.

  mooly 08:59 26 Sep 2008

Bought a Lidl USB cordless mouse. Cannot get it too work at all. Instructions are very clear, it should be just "plug and play" and if you want to use all the configurable features install the software from the supplied CD.
Tried both. New hardware recognised, Vista tries to install drivers and fails. Says something like ( should have written it down ) driver is missing a file NTF or NTI, and was the software for the device written for Windows NT -- please contact the hardware vendor for updated drivers.
So tried the disc. Seems to install the software OK but no response from mouse.
A balloon mesage in the system tray says " device driver installation was not successful"
Never had any problems with Vista and plug and play before.
Just done a system restore to put all back as it was.
Anyone else used Lidl mouse OK it's the NM 1005 -m

  mrwoowoo 03:41 27 Sep 2008

Try installing from cd with the UAC turned off as it may be conflicting with the Vista driver.
Control panel> user accounts.

  mooly 07:25 27 Sep 2008

Thanks for replying. Decided to take it back, and am now using a "Trust" cordless mouse. That one installed with no problem, instantly recognised and all correct using Vista's own drivers.
In the end I restored back to an "image", fortunately taken the day before to make sure I got all the software files off the PC.
I will remember to try the UAC trick next time.

  waste_not_time 22:30 27 Sep 2008

Same for me. Looks and feels a good mouse (although it has a cheap looking USB connector on the dongle) but won't install on my Sony laptop running Vista. In my case the install bubble says that the installation has been successful, but unfortunately it also says "Unidentified device" - so it doesn't work anyway (even with UAC disabled). Plugged it into my dell desktop (also Vista) and it installed correctly straight away - aarrgghh!!

  mooly 14:27 30 Sep 2008

Sorry for not replying sooner -- when you tick resolved does that stop you getting auto email notification I wonder.
Interesting you tried it with the UAC disabled.
It's not the first time I have had issues with Lidl stuff. As you say the quality "feels" fine, but they can be quirky. I have a large LCD clock with auto setting which is so critical on positioning to receive the broadcasts that I have a special position marked out where to place it to get it to update. No big deal, took the first one back-thought it was faulty but they were all the same. Next time they were on offer that feature had been "removed". Their "All in one " remotes are another, won't learn some makes and models, notably Sony and the clock on the display is "frozen" whenever a button is pressed. So if you spend 2 minutes a day pressing buttons the clock will have lost 2 minutes. Ah well !

  mooly 14:30 30 Sep 2008

Nearly forgot -- the dongle -- when it works OK in your Dell is there any LED lit inside it. I too noticed the rubbish USB plug, wondered if it could have been that not making connection properly.

  anthony2007 12:24 24 Mar 2009

Recently moved address and cannot locate my installation CD to install silvercrest 12024 digital mouse, would appreciate your help to locate an installation CD for my Silvercrest mouse or point me in the right directions to obtain installation CD.

  NereliZ 23:22 13 Jun 2009

I broat that mouse too, "Sylvercrest" MTS2218-M, and heave a problem. My mouse wheel adjusting the volume insted scroling the pages. In propeties mode is selected that mouse wheel should scroll pages. So can anybody, help me and give an advise, wich realy would help me.

I'll be wery gratefull.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

ManvsMachine and other artists put Apple's iMac Pro to the test using powerful rendering tools

What to expect at Apple's 27 March education event

Comment filmer l’écran d’un iPhone ?