Philips External Hard Drive problem

  hexane 15:40 10 Jan 2009


I have a Philips 250 GB external hard drive (SPD5110CC) which has been working fine, until this morning, when connected to a PC running Vista Home Premium SP1.

Now, when it is plugged in, it is not recognised by my PC and it causes Windows Explorer to hang - it no longer shows up as a drive in Explorer. Likewise, it causes the Disk Management section of Adminstrative Tools - Computer Management to hang. Unplugging the USB connection to the HD immediately restores the functionality of both Windows Explorer and Disk Management.

The HD still works without any problems on a PC running XP Home SP3 so it doesn't appear to be a mechanical fault with the HD.

I've also tried three different USB sockets on my Vista PC but it makes no difference. Also, another external HD is continuing to function normally on my Vista PC.

A system restore has not solved the problem.

The Philips drive didn't come with any dedicated Vista drivers and up until today has worked faultlessly.

I would appreciate any thoughts on what might be wrong.

Thanks, Roger

  Kevscar1 16:43 10 Jan 2009

This might help.

click here

  hexane 17:44 10 Jan 2009


Unfortunately I'd already looked at the website and the manual but there's nothing relevant to my problem.


  Was Bike Bloke 12:02 03 Mar 2009

I have almost exactly the same problem with my LaCie USB hard drive. It's been fine but is now no longer lisyted in explorer or Device Manager. The Laptop (Dell Inspiron 9400) chimes when it's connected/disconected but shows nothing. It works fine on an XP laptop. Did you get anywhere? can anyone help?
Be well

  hexane 12:49 03 Mar 2009

In the end I took advice from another forum to reformat the external hard drive. This I did and it's worked fine ever since.

I put the problem down to some quirk of Vista because the drive was always readable on my XP machine. It's was only when plugged into my Vista machine that I had problems.

Cheers, Roger

  Was Bike Bloke 17:48 07 Mar 2009

Thanks Roger
Finally gave in and reformated the drive on an XP laptop....made no difference.
Tried the 'delete infcache' solution, deleting USB and Drive files in Device manager.
Situation still exactly the same....Tried differnet registry repair tools....nothing
Anyone got any more ideas.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts