Olympus Camera has stopped connecting. Windows 7.

  jondavey 01:43 08 Sep 2019

Hi everyone, I have an Olympus camera and all was find. But inexplicably it has stopped connecting to my PC. Which is a Windows 7 computer. It is a USB connection, the printer will connect/disconnect with no problems and the camera used to until just yesterday and there has been no significant system changes as far as I know. There seem to be more entries in the Device Manager for USB connections and I tried to delete a few but this always results in the disconnection of the mouse, so I have to stop. Till just recently I would plug the camera in, the system would make a bing bong and it was done. But now the device manager always tells me it has found some kind of Sky box that I know nothing about. Does anyone know why the system isn't seeing the device, why it isn't and what I should do about it ? Thanks for your time ! Jon

  jondavey 15:53 08 Sep 2019

67 views and no one single suggestion ? Was it something I said ?

  Ken Thesparky 16:10 08 Sep 2019

Try installing Picasa 3 it will find your camera and ask you if you want to copy photos and keep in camera or copy and delete camera photos.

  Fruit Bat /\0/\ 16:59 08 Sep 2019

OK sounds as if the registry has conflicting USB drivers. try using the Nisoft USBdeview make sure you download the correct version 64 or 32bit to suit your system.

leave the camera unplugged - you can then use it to uninstall all non connected devices. then restart the PC - Power- restart (not shutdown).

Once the PC has restarted then connect the camera and see if it is recognised.

  jondavey 07:36 10 Sep 2019

Thank you Ken and Fruit Bat. I'll try both of those. Cheers, Jon

  Secret-Squirrel 08:37 10 Sep 2019

........and the camera used to until just yesterday..............

Restart your computer if you haven't already done so.

Till just recently I would plug the camera in, the system would make a bing bong and it was done.

What "was done"? Did a program start automatically or were you presented with a dialogue box asking what you want to do? If it's either of those then may be it's something as simple as your AutoPlay preferences need tweaking. If you connect the camera and it appears in "Computer" then my hunch may be correct.

  jondavey 09:55 10 Sep 2019

Actually having tried both of those I have found I still am unable to connect the camera. That google software is rubbish and the other program just didn't work at all ! But perhaps it's because I don't know how to use command line programs....

  jondavey 09:56 10 Sep 2019

...isn't there a way I can just delete the USB devices that aren't being used which seem to be confusing my system ?

  hssutton 15:19 10 Sep 2019

Are you sure the USB port on the camera is not damaged, many people over the years have had problems with a damaged USB port on their cameras. To use the USB connection on my my Canon cameras they have a small screw to secure the USB connector in position so as to avoid damage. Having said that I would never use the USB, Far easier and safer to use a card reader.

  jondavey 00:28 15 Sep 2019

I guess there's a posibility that the actual USB on the camera side is faulty. A card reader would solve this. I'm thinking this might be the way forwards. Thanks hssutton ! nice work !

  jondavey 00:30 15 Sep 2019

....having said that there is a front pannel on my PC that reads verious cards. I might already have the solution if I'm lucky. Fingers crossed !.....

What is Markdown?

Markdown lets you add more formatting to your post. Simply type in your post and it will display as written.

If you wish to add bold or italic characters, add a hyperlink to another website, a heading or a horizontal line, simply use the relevent icons above the text input field.

A preview of your post will appear in the grey box below. If you make a change and you're not happy, simply press the back arrow icon to undo.

Post a Reply

4500

Elsewhere on IDG sites

iPhone 11 Pro vs Huawei P30 Pro: How Pro should you go?

IBC 2019: new video tools from Adobe, Blackmagic, Lenovo and more

iOS 13 release date, time & new features

Les meilleurs appareils connect├ęs compatibles avec Google Home (2019)