No Mouse Control - Registry / driver problem

  tallboy 10:10 18 Nov 2013

Trying to re-install Kapersky s/w on my 64-bit Win 7 system, (after going back a week in Reg-Edit restore points it didn't work) I re-ran Reg-Edit and obviously ticked some delete boxes (by accident) that I shouldn't have done!

Now I am unable to move the mouse - either in Normal or Safe mode. I have tried using the repair tools on the original Win 7 disk, but I am unable to get the type of Operating System to show up - hence can't use Windows files loaded from CD to go back to a previous restore point.

How do I get the Mouse working again from the Command Prompt? If I can (and Windows starts up OK - which I think it is doing apart from the mouse not functioning)

Alternatively, if someone can suggest a link to a website where I can download the appropriate s/w for the mouse (only) I might be able to use Windows Repair again to install the necessary files.

All suggestions welcome. Thanks. Tallboy

  xania 12:22 18 Nov 2013
  tallboy 23:19 18 Nov 2013

Thanks for all the posts. Unfortunately I'm not any further on.

I tried Jock1e suggestion (since I have a desktop) and clicked on Last Good Configuration, but sadly it hasn't worked. I thought it was doing the repair, since when I gently pushed the off button, I got the on screen message (above the log-in images) 'Operations are in progress, please wait. The machine will be turned off automatically after the operations are complete' - which it was. When I turned the PC back on again, it started up in the normal Windows mode, but with the mouse pointer firmly stuck in the middle of the screen - as if the mouse wasn't working. However, the mouse is OK since if I boot from the installation disk, I can control it.

The Windows install / boot disk lets you do a System Restore, but it asks for your operating system. I would have expected to be given I selection in the Drop Down box that comes up - but it is blank. How do I 'tell' it what OS I have?

I do have a separate Intellipoint installation disk. If the problem is a corrupt set of pointer drivers, (which I suspect it is) is there anyway I can use this in conjunction with the Windows Install disk to re-install them?

Also if the above 'operations in progress' is unplugging the mouse, starting up and then shutting off followed by switching back on with the mouse plugged in (so that Plug & Play can find the mouse - assuming it is working) likely to solve the problem?

The keyboard works OK Jock1e, but since I can't get past the log-in screen (in either safe of normal modes) I can't use the Windows key. It seems that the only thing that you can use in the Windows Install disk.

As a last resort, I do have a System Image disk - but this in 2+ years old, so I am very reluctant to use it if the problem (getting the mouse working) can be solved via via a Command Prompt.

Any more things I should try?

  tallboy 08:16 19 Nov 2013

Thanks for the quick reply & suggestion Jock1e. Yes, I have another mouse I can try - just about to do that.....Tried, but no luck.

I forgot to mention in my last post, at the time of last working shut down, when I had been trying to re-install Kaspersky Internet Security, Kaspersky displayed a message saying 're-boot now - installation will continue after reboot'. Since on re-boot there was no mouse control (hence no login) I can't tell whether the Kaspersky install continued, or added to / caused the problem. Prior to undertaking the Kaspersky re-install, I ran Kaspersky's online virus checker' it didn't report anything untoward.

I'l try booting from my O&O Disk Image disk to access the command window. It has (I think) better tools than the Microsoft boot / install disk.

  tallboy 08:42 19 Nov 2013

Just tried O&O disk - it didn't allow me to get to a Command Prompt, so I was unable to enter rstui.exe.

Incidentally, the Microsoft install disk didn't pick up / show the fact that my PC is a Windows 7 system (hence couldn't get any further on the relevant screen) -but the O&O disk did.

I guess I'll have to call in the 'professionals'!

  tallboy 20:54 19 Nov 2013

Hi Jock1e. You get the same result whether you log on in normal or safe mode - a 'stuck' mouse pointer.

I have already raised a 'Ticket' at Kaspersky (on Sunday) and am awaiting their reply with suggestions. Haven't had a reply yet, but they have indicated that it is their current 'work' queue.

Yes, I am using a USB mouse. I think I still have a PS2 mouse and should have an adapter for it (somewhere!). However, late this afternoon I took the machine to our local PC repair chap (who has a good reputation in this area - and he is hoping to look at it tomorrow. He has all the necessary tools & knowledge to work out what is causing the problem. I'll post what he discovers on this thread.

  tallboy 22:15 22 Nov 2013

It could be a good result, but alas the professional PC chap I took the PC to had to re-install Windows 7 to get any mouse pointer movement. He did try a PS2 mouse, but couldn't get that to work.

Apparently, whereas Windows XP allows you to do a repair install if you have a 'frozen' mouse, Windows 7 does not. So much for Microsoft 'progress'!

I am now going through the laborious process of re-installing the programs I use. Fortunately, I keep all my documents & downloaded applications plus licence keys on a separate partition to the OS (as well as backing them up), so hopefully I won't have lost anything I need.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6 review

Procreate's iPhone app offers new brushes, a larger canvas and better support for the iPhone 8/X

Best multi-room speakers for iPhone & Mac owners

Streaming : comment regarder le lancement de Xiaomi en France ?