New usb3 pci card not mounting usb3 external drive

  gossylad 21:49 30 Jan 2010

I recently brought a 2tb usb3 Buffalo Drivestation to utilize the new usb3 super speed.

I only have usb2 ports on my pc, so invested in an Icy Box usb3 pci-e expansion card to make it run on my pc.

So, after installing the pci card in my pci x1 slot and connecting a 4pin molex connector from my psu to it. I then loaded the NEC drivers etc that came on the cd with the pci card.

But after restarting my pc and plugging in the new Buffalo drive all I get is the drive flashing blue as it reads it. But the drive itself will not mount on my pc.

I have tried the usb3 cable in my usb2 ports and it works fine (albeit instead of a blue light I get a green light). Also, I have plugged other drives into the usb3 ports on the new pci card and they all mount fine too.

I can not understand why my pc is not mounting the drive after it starts to read it when I insert the usb3 cable into the usb3 port on the new pci card. Do I need to update my bios, as I have tried everything else.

I have tried it with just the new drive plugged in to see if I had too many drives on the system, but still it does not mount.

I have an Asus M4A78 Pro motherboard, 500w psu, amd triple core cpu, 1tb hard drive, 2 dvd drives, 4gb ram, nvidia graphics card, netgear wireless card and the icy box usb3 pci expansion card. With attached to usb ports: 1 Epsom printer and external drives: 2 1tb Buffalo, 1 Freecom 400gb, 1 Lacie 1tb and the 2tb Buffalo usb3 drive.

I can't see how the card does not have enough power to read and mount the drive as the Bufallo drive has its own power adaptor and the Icy Box pci card has a 4 pin molex connector so that it can receive extra power from system.

Have also tried just plugging the card in without using the 4 pin molex to see if that power supply was clashing with Buffalo drives power supply, but no. Also, tried just plugging in the Buffalo drive just by usb3 port and with out using its own power adaptor, but no.

So am now stuck with a new usb3 pci card that doesn't mount usb3 drives and a new usb3 drive that will only mount through a usb2 port!

Any help or suggestions would be greatly appreciated and it if works will be highly praised with thanks!!!

  BRYNIT 22:06 30 Jan 2010

Already posted in Help room click here and Absolute beginners click here

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

How Pentagram and other design agencies aim to double the number of creative female leaders

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?