iTunes - a rant

  Kate B 12:58 22 Apr 2007

I love iTunes as a music library and to manage my iPod but it is driving me mad that Apple hasn't bestirred itself to produce a version of it that plays nicely with Vista. The latest version is supposed to be Vista-friendly, but it's very flaky - I know Apple and Microsoft are never going to be the best of friends but this is really annoying me.


  anskyber 13:06 22 Apr 2007


  HappyTrucker 15:06 22 Apr 2007

Kate. can I ask what problems you've been having? I've been using iTunes with Vista for a couple of weeks or so and had no issues at all - yet.

I'm wondering if it's like the early stuff with XP - some people could run program X with no issues, but someone else with a different software/hardware configuration would have problems.

  Genius1 17:56 22 Apr 2007

I'm having no issues at all with the latest iTunes and Vista Home Premium.

  powerless 18:15 22 Apr 2007

Yes I would like to know what problems you are having.

  Why wont it work 19:03 22 Apr 2007

I can report *touch wood* that I've had no problems either. My only gripe is it no longer looks 'pretty' in comparison to WMP 11 etc!

  Kate B 19:04 22 Apr 2007

I'm glad you guys are not having problems - maybe I'm just unlucky. Sometimes I get a black hole on the monitor where the iTunes window should be: in other words, it doesn't finish loading; and syncing my iPod is very hit and miss. I've tried reinstalling iTunes and it continues to be flaky.

  powerless 19:38 22 Apr 2007


Turn Aero off and then see if it does it.

  Probabilitydrive 20:31 22 Apr 2007

I'm about to join the Vista club and are-naturally- paranoid of grinding earth to a standstill....

Trying to prepare myself for the inevitable, I came across this i-tune vista tweak, which may (or may not) does the trick.

right click on the iTunes.exe program icon in the iTunes folder.
select Properties.
click on the Compatibility Tab and enable the 'Run this program as administrator ' tickbox.

  Kate B 00:28 23 Apr 2007

Good idea, I'll try it in non-aero; and I'll try the run as adminstrator option.

  Forum Editor 07:08 23 Apr 2007

and haven't experienced this problem - or any other - since Apple released the latest version. I run it in Aero, too.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Honor 9 Lite review

How Sam Falconer transforms science and geology into digestible, elegant illustrations

HomePod review

Les meilleures séries Netflix (2018)