Internet not connecting from the desktop

  jpemberton 13:26 21 Feb 2013

First of all, my Internet Explorer icon disappeared from the desktop. I found that was because Browser Choice had taken it off, so I managed to get it back on again but it won't connect to the Internet. I can get Internet through Internet Explorer on the Windows 8 Start page, but not from the desktop. I have tried refreshing the computer and also tried System restore - but nothing happens! 'Preparing to restore' or 'Preparing' appears, but no more than that. It sits there for as long as I leave the machine on. I cannot get rid of Browser Choice either. Please help before I throw the laptop out of the window!!

  chub_tor 16:22 21 Feb 2013

If you Google remove Browserchoice you will find several entries this is one of them

  rdave13 16:23 21 Feb 2013

How did you get the IE desktop icon?

  jpemberton 18:32 21 Feb 2013

I have tried to remove Browser Choice but it refuses to go! Chub_Tor, the example you gave applies to Windows 7, but I have tried the suggestions I have found in Google without success - but thank you anyway. I got the Icon back by right clicking on the Internet Explorer app, which brings up 'pin on desktop' - which I did. The icon is there, but clicking on it brings up a window which just doesn't connect to the internet. I'm going to take the computer back to the shop tomorrow and see what they can do about it.

  rdave13 18:55 21 Feb 2013

So it's pinned to taskbar. Open IE in the taskbar and click the tools icon, internet options, advanced tab and reset IE. Close and open again, see if that makes any difference. Also go to control panel, default programs, set your default programs, click on IE and set as default.

  jpemberton 20:26 21 Feb 2013

Thank you rdave13. I've tried all you have said - and still no joy. Back to the shop tomorrow. I have discovered the AMD graphics aren't working (apparently - don't know what it means) so I have tried to update that, but it won't respond. Something isn't quite right somewhere. Will let you know.

  jpemberton 18:28 22 Feb 2013

All sorted - till next time! It was all due to an update which caused a glitch in the system apparently. Thank you for your suggestions.

  rdave13 18:31 22 Feb 2013

Thanks for your reply. Hope the update is now hidden for your set-up.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Meilleurs drones (2018)