Installation of programs - corrupt 'All Programs' list

  Pine Man 18:26 22 Aug 2014

Windows 7 64bit.

When I install a new program on my PC it's folder appears in the 'All Programs' list but it is empty. It should, obviously, contain shortcuts to the application files etc.

If I try to delete that empty folder it won't let me as I 'don't have the authority' and it's properties show that it is 'Unable to display current owner'.

I have run a variety of malware and av checks and all is clear.

This has happened with all recent installations over the last few months including Silverlight installed as a Windows Update. I hadn't actually tied it down to installation until now and, as it happens, one uninstallation where a program was uninstalled but it's entry remained in 'All Programs' and couldn't be removed.

Any ideas?

  rdave13 19:13 22 Aug 2014

Try Microsoft's installer fix it, click here.

  rdave13 19:15 22 Aug 2014

Link goes to 64-bit version automatically for me, hope that's ok.

  Pine Man 19:31 22 Aug 2014


Should have said - I tried that but thanks anyway.

  rdave13 19:41 22 Aug 2014

You could run sfc /scannow in CMD as admin. Do you use any 'optimizing' programs other than Ccleaner? That might be your problem.

If you run system restore that would be my first port of call, to a time when windows installer was not corrupted, if successful, I would uninstall any third party optimizing programs if you use them.

  Pine Man 08:17 23 Aug 2014

Good morning rdave13

Ran sfc /scannow - no problems found.

No optimizing programs installed.

System restore doesn't have any points far enough back.

Bit of a doomer really but all of my programs actually work it's just that the most recent ones installed cannot be run from 'All Programs'. I have actually tried putting entries in 'All Programs' manually and they work perfectly.

Bloody windows!!

  rdave13 09:00 23 Aug 2014

Have a look at this thread, click here. chriso32 has a suggestion.

  rdave13 09:10 23 Aug 2014

Also have a look at the post on 27 Jul 2013

  Pine Man 09:16 23 Aug 2014

Thanks for that link.

I have been 'playing' a bit this morning and found, also, that it is all to do with permissions for the folders and files. If I take the time to change the permissions on all affected folders and all affected files within the folders everything is then ok, BUT, when I install new program it has the same problems.

The solution offered in the link doesn't work because the previous folders aren't old enough.

All I need to do now is find out why the wrong permissions are being applied to folders in the 'All Programs' list. Easy Peasy;-)

  Pine Man 11:46 23 Aug 2014

Now getting the following when installing a new program:-

'Warning 1909. Could not create shortcut 'my program' file manager.lnk Verify that the destination folder exists and that you can access it.'

If I manually create a folder in 'All Programs' and then take ownership of that folder the program will install shortcuts in it. This still does not answer the question - why is it necessary to do that?

I seem to be going round in circles and do get frustrated with Windows that's why I bought an iMac a couple of months ago and let my wife have the PC (which I still have to try and fix from time to time!!)

  Pine Man 12:02 23 Aug 2014

Just tried to install other programs and the result is always the same. The permissions for those programs in 'All Programs' have to be altered to allow access before they will work.

The programs all work okay it's just the shortcuts in 'All Programs' that don't until modified manually.

I guess I (my wife) will have to live with it unless I spend a day or so completely reinstalling windows and all the software and drivers. Naaah she'll have to live with it:-;

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)