IE 64 can connect to internet, IE 32/Google Chrome cannot

  d_seng 20:47 08 Apr 2012


I have a Windows 7 Professional 64 bit o/s, running IE9 32 bit & Google Chrome.

Today, all of a sudden, after configuring and starting up Windows Virtual PC, IE and Google Chrome have stopped connecting to the internet, giving the dreaded message "Internet Explorer cannot display the webpage". Even when I try to connect to my router, it still gives me the same error. If I use putty to connect to my NAS box, I get a similar message.

At command prompt, I can ping to the router, the NAS box and the different websites.

However, I am able to connect to the internet (and the router and the NAS) using IE9 64 bit, and also connect to the internet using the built-in browser in a software called DAP. All other devices in my house, mobile, TV, etc. can connect as before.

I have disabled Windows firewall and also uninstalled the antivirus program (Virgin Media Security - Trend Micro).

I have run out of reasons I can think of.

Any help greatly appreciated.

Happy Easter!

Cheers, Dhruva

  difarn 08:25 09 Apr 2012

Is the virtual pc connected to the network host of the host pc ? If not try this. If this doesn't work and you have any other network adapters installed try those.

  d_seng 07:12 10 Apr 2012

I tried all the different network options, but with no success.

I removed the virtual machine altogether, but it still doesn't work.

Still lost!

  difarn 12:36 10 Apr 2012

You may find this article useful and it's solution.

  d_seng 18:41 10 Apr 2012

Hey difarn, I owe you one!

I did not have to uninstall SP1 (I never had SP1, it fails to install everytime - about 12 times in 6 months).

I tried netsh winsock reset, rebooted the laptop and voila, it works!

  difarn 09:07 12 Apr 2012

Glad it's sorted.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)