IE 11 shortcut disabled by Opera

  Brighstone 00:14 22 Dec 2013

I installed Opera on my Windows 7 PC to try it and it converted all my IE shortcuts to Opera. Now I have uninstalled Opera, all the shortcuts remain altered to the Opera icon and will not open in IE. How do I revert them to opening in IE?

  Secret-Squirrel 11:19 22 Dec 2013

" IE shortcuts..."

Are those shortcut files that contain a web address? If so, and you want IE to be your default browser, then try this:

1) Go to Control Panel -> Default Programs -> Set your default programs. In the left-hand pane select Internet Explorer then click the "Set this program as the default" option. That action will also associate your .URL files with IE.

  Brighstone 12:33 22 Dec 2013

Hi Secret-Squirrel

Many thanks - your advice worked a treat in that the main problem, which would have meant me re-installing Opera, has been overcome. A more minor problem remains which you may be able to help me with. Each short cut still retains the Opera icon although it will now open in IE. I've figured out how to change the icon individually for each icon (right click - properties - web document - change icon) but is there a way for changing all of them in one go as I have many such short cuts filed away and to change them all individually would be a mammoth task. I have CCleaner and have used it to clear 2 Opera left overs in the registry but that had no effect.


  Secret-Squirrel 16:55 22 Dec 2013

"Each short cut still retains the Opera icon although it will now open in IE"

Oooh err, that shouldn't happen as all the icons should now be displaying the IE logo. Have you tried refreshing the folder view by pressing F5? Or perhaps a reboot will make things come good.

  Brighstone 21:40 22 Dec 2013

Thanks for coming back again. Tried F5 and a reboot but they didn't change the icons so it looks as though I will just have to accept it unless someone comes up with an answer.

  rdave13 18:26 23 Dec 2013

Try rebuilding the icon cashe, auto help here.

  Secret-Squirrel 08:46 24 Dec 2013

Hi Dave

I'm not sure that your link will help because of the following message on that webpage:

"This will not help with any of the following icon issues: All icons for a specific file extension display the wrong icon.".....which is exactly what the OP's problem is.

However, that page links to this which looks more hopeful. The Registry fix for .URL files is included in the list.

Brighstone, before doing anything to the Windows Registry, create a System Restore point first in case it makes things worse.

  Brighstone 22:56 25 Dec 2013

Hi Secret-Squirrel

Thanks for the latest. Have downloaded the registry fix for URL plus a short cut to the instructions as to how to use. Also done a restore point but at the moment, being a relative beginner in these things, have chickened out of touching the registry. Will dwell on whether or not I want to take the risk or should I just put up with what is at the end of the day just a cosmetic annoyance.


  Secret-Squirrel 09:50 26 Dec 2013

If this were my problem, I'd have no qualms about applying that Registry fix. is a reputable website.

When you create a System Restore point it backs-up the entire Registry. In the unlikely event of things not working as expected, run System Restore and choose that restore point you created.

I recommend that you try applying that fix - especially as it claims to fix your problem with all files showing the wrong icons.

  rdave13 12:01 26 Dec 2013

Option 2 here might be a better alternative if not keen on changing the registry. Once you've opened 'Default programs' scroll down to 'URL' double click and select Internet Explorer. Similar to SS's first suggestion but the other way round!

  Brighstone 16:17 27 Dec 2013

Hi Secret-Squirrel

Tried the registry fix in a Standard account without success. Tried again in an Administrator account (as recommended by the site if the Standard account attempt did not work) but unfortunately with the same result, so have used System Restore to revert the PC to its former state.


Attempted to do as you suggested but could not arrive at a screen where I was able to double click url and select IE. Would be grateful if you would give me the trail of exactly what to click on in a chronological order as I clearly must be doing something wrong.

Very much appreciate the help you both have been giving me.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy S9 review

Wacom Cintiq Pro 24 and 32 review – hands-on

When is the next Apple event?

Gmail : comment annuler l’envoi d’un e-mail ?