I need to disable my touch screen

  rc58 16:50 11 Jul 2017
Locked

This morning, my touch screen is going crazy. I didn't touch it, or actually ever use it. There are spots all over my screen as though a thousand flies are on it. Boxes open and close at a frantic rate. I just want to disable the touch screen on my Dell Inspiron 15 5000 series. There is no option under devices, and I can't find anything under disk manager. Any help?

  wee eddie 17:23 11 Jul 2017

Maybe you really are infested with Thunder Flies. Is that possible?

  rc58 17:53 11 Jul 2017

lol, I wish it were that simple. There is nothing touching the screen. Once it did have a fly on it that had landed on a sticky fly strip. One leg stuck and he just went round and round, setting off the screen.

  Fruit Bat /\0/\ 17:58 11 Jul 2017

Open Device Manager and search for Human Interface Devices. Expand it. Right-click on HID-compliant touch screen and from the list of options displayed, select 'Disable'

  rc58 18:25 11 Jul 2017

Thank you, Thank you, Thank you! That worked!

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Amazon slashes Echo Dot price to just £24.99 to kick off Black Friday

The 51 Best Free Typefaces Every Designer Should Have

Mac mini 2018 review

Les meilleurs écouteurs et casques audio (2018)