I Can Ping but Can't Browse on any platform

  alig301 22:00 11 Jul 2015

Hi all,

I have a very frustrating and annoying issue: I can successfully "ping" website names and IP addresses from the command line, but all of my internet browsers say "page cannot be displayed" or "Server not found." I also cannot update my Kaspersky from the application.

Machine: Win7 x64 Home Edition

I have tried everything I can think of:

1) Basics: Wifi switch, network cables 2) Repair Adapter 3) Restore (restore fails) 4) Boot in Safe Mode w/ Networking 5) Virus/Malware/Rootkit/Adware Scans 6) Ran HitMan Pro 3 7) ipconfig /release /renew 8) Flush DNS 9) netsh winsock reset 10) No proxies set -> all default obtain automatically. 11) Uninstall all 3rd Party Firewalls/Antivirus, Turn Off Windows Firewall

I think it must be a Windows setting since it still happens in Safe Mode with Networking, but that's just my hunch.

I'm really stuck on this one and would appreciate any help. Happy to post other details if required. I am sure I have tried a few more bits but my head is fizzing

Thank you very much!

Kind Regards Al

  Govan1x 22:31 11 Jul 2015

Any yellow exclamation marks in Device manager

  Govan1x 22:33 11 Jul 2015

Could it be the network you use is down.

  Govan1x 22:37 11 Jul 2015

Not got work ofline ticked. it used to be under File on I/E toolbar.

  alig301 22:41 11 Jul 2015

No exclamation Marks in Device Manager.

Other devices working fine.

Same accross Chrome, IE11 and Firefox

  Secret-Squirrel 09:18 12 Jul 2015

I can successfully "ping" website names and IP addresses from the command line

That's a good test and it shows that Windows networking and name-resolution are fundamentally working at core level.

9) netsh winsock reset

Because of what I've said above, I doubt this suggestion will help but you could reset TCP/IP using netsh int ip reset resetlog.txt from an elevated Command Prompt window.

3) Restore (restore fails)

If you mean you tried a Windows "System Restore" then you'll have a much better chance of success if you run it in one of the Safe Mode options, or even better, the "Repair your computer" option which runs outside of Windows:

  alig301 09:26 12 Jul 2015


Previously tried restore form safe mode and netsh int ip reset resetlog.txt from an elevated Command Prompt window.... no joy.

Kind of stuck where to go next.

Regards Al

  Secret-Squirrel 09:41 12 Jul 2015

Previously tried restore form safe mode

When you said earlier "restore fails", do you mean System Restore itself failed or do you mean it succeeded but failed to fix your problem? If it's the former then try my suggestion.

  Secret-Squirrel 12:39 12 Jul 2015

I found this thread from nearly two years ago and it's so similar to this one that it must have been started by you. Have you really had the same problem all this time? If you have then there's no point trying a System Restore as no restore points that old will be available.

  alig301 14:57 12 Jul 2015

No it wasn't me, I also found it and have identical problems but I couldn't see a resolution on that one. The restore didn't work 'failed to restore'. I have managed to resolve it by using Window Repair (All in One) from Tweaking.com so big thanks to them and thank you all who assisted.

kind regard Al

  Secret-Squirrel 16:06 12 Jul 2015

No it wasn't me

The formatting is very similar and some of the sentences are identical so that's one astonishing coincidence.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro (2019) review

Inside the redesign of the world's largest computer games platform, Steam

Apple Streaming Service Release Date & Apple TV Subscription Rumours

Quel antivirus gratuit choisir pour un PC ?