Hard Drive Error Message -this device is not ready

  ShinySnail 11:38 16 Feb 2018
Locked

Hi, I have tried to copy some data from one external hard drive to another, and part way through there was a reoccurring error message where a photo wasn't copying properly. I couldn't get out of the loop so shut down the open window but when I tried to eject the hard drive it said that the device was currently in use. I waited an hour to see if stuff needed more time but it still wouldn't work, so I ended up shutting down the computer without ejecting the hard drive properly.

When I went back in I completely deleted the files from the hard drive that had been partially added, and tried to re-copy them back over - but this time I got an error message to say that the device is not ready.

I now also cannot access any of the existing files that were on the hard drive, they all say 'not accessible, the device is not ready' and again I cannot properly eject as it says that it is still in use.

I tried to scan for errors but got another message to say that a scan could not be performed.

I know NOTHING about computers, and am terrified that I might lose the data that was already on this hard drive (that incidentally isn't mine, I borrowed it from my husband and it has all his precious stuff on it!!!!)

Please help, please! lol
Thank you, Anna

  chub_tor 12:47 16 Feb 2018

The first thing I would try is the free version of Piriform Recuva Click Here it will at the very least show you which files are available for recovery and is easy to use. You may need the paid for version to get all your files off. If Recuva does not work for you my next step would be the EaseUS programme Click Here but the free version is limited in the number of files it can recover. The paid for version to recover all your files is much more expensive that Recuva.

  Fruit Bat /\0/\ 13:54 16 Feb 2018

If its showning in Explorer right click it and select properties - then select the Tools tab - Click or Check and run a disk check on the drive.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy Book 2: Release date, price and specs

This First Man soundtrack vinyl cover art is exquisitely composed

How to watch Apple’s October 2018 iPad launch

Meilleurs VPN (2018)