file no longer in specified location

  cgguyy 15:57 04 Mar 2012

I am trying to backup a large number of music files to a usb connected hard drive. The drive works fine when I back-up documents but when I try to back-up the music files all I get is a message saying 'file no longer in specified loaction'. This happens whatever method I try - the official backup program, goodsync, drag and drop, Cntr C/Cntr V. I have even tried the command prompt (run as administrator) and done a copy .. Nothing works to copy, but the files are there - they can be played on the PC with no problems. Any ideas?

  difarn 18:43 04 Mar 2012

When you are transferring the music files are you trying to copy individual tracks or a whole folder. Will it work if you create a folder on your PC and another named folder on your usb external hard drive and then right click on the folder on your PC and "send to" your external hard drive?

  cgguyy 11:41 05 Mar 2012

I have tried both - single files and entire directories - with the same result. I will try the 'send to' approach tonight, but i am not hopeful.

  difarn 12:37 05 Mar 2012

If that doesn't work there is a possibility that a system file has become corrupted. You could try to check and repair this by....

To run the System File Check and Repair tool, follow these steps:

Click Start
and then type cmd in the Start Search box.
Right-click cmd in the Programs list, and then click Run as  administrator.

At the command prompt enter the following line, and then press ENTER:
sfc /scannow

When this has finished see if it has resolved the situation

  cgguyy 10:08 06 Mar 2012

I am afraid that this didn't help. The scan reported no problems. Someone suggested that itunes might be causing the problem so I uninstalled that (properly, not just deleting). After a reboot I was able to drag and drop one folder across, then when I tried the next one the old problem returned 'file no longer in specified location'. Very strange. The 'send to' option gave the same result. I am certain that the music files are where they are supposed to be as a command line 'dir' shows them all there, and they play correctly.

Another suggestion, which I am tempted by, is to boot to Linux (from CD), copy the files under Linux, then install Windows 7.


  difarn 12:34 06 Mar 2012

Have you tried to back up your files using the Vista Back Up Wizard? You can just do it for your music files if you wish. It will be interesting to see if the same thing occurs. Here is a link to an article.

  cgguyy 12:55 06 Mar 2012

yes, I have tried that and it comes back (after a long time) with 'Backup failed'

Thanks for your advice.


  difarn 18:00 06 Mar 2012

Is the music that you are trying to back up as a result of downloads via iTunes? I am wondering if that is the problem and in fact iTunes does move files to different locations. Came across this article which may be of interest to you about transferring your iTunes library, including onto an external hard drive. It just may throw some light on what may be happening.

  cgguyy 10:49 07 Mar 2012

Hi, Thanks for that but sadly it didn't help much. Most of the music is downloaded from a service called emusic and the rest are ripped CDs. We did have itunes installed but I have now uninstalled it (I did the proper procedure not just deleting the files). In one of the responses in the article it mentioned NTFS Junction points and I wonder if it is something to do with that. I will try to read the documentation and see if anything comes to light.


This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Why this awful City of Los Angeles job ad for a graphic designer is actually brilliant

iMac Pro review

Les meilleures prises CPL (2018)