External HD suddenly not recognised

  Skeletor 18:07 07 Mar 2012

Hi all,

I have a Lacie 250GB firewire external HD (couple of years old) which I use as a backup device. It's only used (switched on) about once a month.

Everything has been fine until yesterday. When I switch it on, the light comes on and it whirrs into action as usual, but, rather unusually, Windows 7 (32bit) starts looking for a driver and then says, "Device driver software was not successfully installed". The HD, unsurprisingly, doesn't show in "My Computer" but does show in "Device Manager".

I have uninstalled and reinstalled the HD, but still no joy.

I have a separate 64bit partition (used exclusively for music) on the PC which does recognise the HD, so all is not lost, and leads me to think that the HD or cable is not the problem.

Any help much appreciated.

  difarn 19:14 07 Mar 2012

Have you tried to assign a drive letter in Disk Management?

Right click on My Computer

Select Manage / Disk Management

With the drive connected, right click on it in the right panel, "Volume" column

Select "Change Drive letter and path", then "Change"

Select a letter and then OK

  Skeletor 20:25 07 Mar 2012

I'm afraid the drive doesn't show in Disk Management, I just get a box telling me "You must initialize a disk before Logical Disk Manager can access it". Which I guess means a format. Can't afford to lose the data.

  difarn 21:37 07 Mar 2012

It has been known for a simple thing to work - try....(if you haven't already done so)

Turn your computer off, then unplug the USB cable and then the power to the drive. Restart you computer, plug the power into the hard drive, wait 10 seconds and then plug the USB into the computer. This clears the hard drive buffer.

Have you tried it on another PC?

  Skeletor 23:10 07 Mar 2012

Thanks for you help difarn.

I had tried all the simple (except one) things to no avail...

Anyhow, all fixed now. Seems it was a dodgy driver. I went to 'IEEE 1394 Bus host controllers' in Device Manager and updated the drivers. I was surprised to see that new drivers were available.

I guess I was too trusting of DriverMax which told me there were no new drivers, and probably installed the dodgy drivers a month or so ago.


  difarn 06:42 08 Mar 2012

Glad it's resolved.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Majority of illustrators don’t earn enough to live from, new survey shows

iPhone X problems

Word gratuit : comment télécharger le logiciel de Microsoft ?