Epson Photo R200 not working on Vista??

  jemjem 09:38 28 Feb 2010

I've recently had Vista put on my computer and now my printer doesn't work. I have tried unplugging the printer, uninstaling any epson software by going to computer- add/ remove programmes. Then deleting the printer in control panel. I then plugged the printer back in and installing various epson drivers such as easyprint 310a. Nothing works :( I've also tried restarting before plugging the printer back in and it's still not having it? Can anyone help?

  Kevscar1 10:45 28 Feb 2010

have you gone to the Epson site to see if there is a Vista driver for your printer.

  Peter 11:31 28 Feb 2010


I think with Epson printers that you must install the drivers from the CD (or download) before you plug in the printer. You will be prompted to plug in and switch on the printer during the driver installation process.


  jemjem 12:18 28 Feb 2010

Hi again, Thanks for the advise.
I've looked on the epson website and there is nothing for this printer and vista. I downloaded the easyprint but as it was the only one that mentioned vista but its not a driver, I also tried one that was for XP, but it wouldn't let me install it. Do you think a driver for a differant printer in the same series would work?

  sharpamat 16:16 08 Mar 2010

The Drivers for the R200 and Vista are on the Epson Website. Try this link
click here
Before re-installing you need to Totally remove all previous versions not just Add/Remove programs ( look at your HD and Deleat them )
If your installing the drivers from the Website. DO NOT plug in and turn on before it tells you this may take a little while

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

No need to scan sketches into your computer with Moleskine's new smart pen

How to use 3D Touch on iPhone

Comment importer des contacts d’un iPhone à un autre iPhone ?