DVD/CD-ROM drives and USB stick not showing

  Star Lord 17:52 22 Jun 2017
Locked

My DVD was working fine a week back now it has stopped for some reason.

I have checked Device Manager and DVD/CD-ROM drives is not showing. I can't work out why. The DVD drive is showing in My Computer as the F drive. When I click on it keeps states insert a disk into the F drive.

In can’t hear the DVD/CD spinning.

Also one of my USB sticks is also not being picked up for some reason. The others are fine. When I connect this USB the PC plays back a sound to show it is connected. Yet it is not showing up in My Computer or Device Manager, it is also not showing in Disk Management.

I can only assume both issues happend at the same time.

Hope someone can help

Thanks

PS I Windows 10 on my PC

  Fruit Bat /\0/\ 12:36 23 Jun 2017

No CD/DVD or CD-ROM access is missing error Code 19, Code 31, Code 32, Code 39, or Code 41 Try this if the optical drives are not appearing in My Computer or Device Manager. (This is sometimes caused by the removal of Roxio or other writing software.)

click here XP_CD-DVD-Fix.zip and save this file to your hard drive. Navigate to where you saved it and double click the file to extract the contents. Locate the EXE file you extracted and double click it. A confirmation dialog will appear when the script is done. You may need to reboot for the change to take effect. This utility is only intended for Windows® XP, but also appears to work for Vista and Windows 7. You may need Administrator level access to use this utility. If you do not have Administrator level access, the program will say it is finished, but will not have made any changes.

Similar fixes click here works for W7 Vista or XP click here manual fix Run regedit and navigate to registry key HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Control\Class\ {4D36E965-E325-11CE-BFC1-08002BE10318}. Highlight it and in the right pane, find the Upperfilters and Lowerfilters values. Highlight each one in turn, right click and delete them. Close regedit and restart the computer. If in doubt make a restore point before making changes.

Download or

  Star Lord 13:05 23 Jun 2017

Hi

Thanks for the above, but it did not work. I have tried both methods, with the utility and without via regedit, still no luck.

The driver is showing in My Computer, however when I click onto it, I get the message "Please insert a disk into CD DRIVE (F:)"

The DVD/CD-ROM drive is NOT Showing up in Device Manager or Disk Manager

Also I'm using windows 10

  Fruit Bat /\0/\ 13:31 23 Jun 2017

try p windows Key - power - restart (not shutdown)

see what happens after a restart.

  Star Lord 11:41 28 Jun 2017

For info only, I fixed my pc by doing this

A fix that has worked for many people is to go in Device Manager and under "IDE ATA/Atapi controllers", delete both the channel 0 and channel 1 entries by uninstalling them. Then reboot the computer. The 2 things will be reinstalled and then your drive may show up. Taken from another forum

  Fruit Bat /\0/\ 16:45 28 Jun 2017

Must be an old machine to have IDE channels showing - didn't expect that when you said you have windows 10.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Red Dead Online release date and gameplay news

Create a glowing superhero

Mac mini 2018 review

Les meilleures prises CPL