DVD Drives have disappeared

  Icky 14:39 09 Dec 2009


I hope you can help.
Dell Inspiron 545.
I did a full install of Windows 7 64 bit about a month ago (not a Dell upgrade) and everything has been running really well until just now.
I wanted to copy a CD and installed 'Tesco Easy Record' which I used with windows Vista. It didn't work and so I uninstalled it. Now the DVD drives don't show in 'My Computer' and won't play any DVDs.
I've tried updating the device drivers for the DVD drives but it says they are up to date but it does give the message "A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)"
I've tried System Restore but this didn't make any difference. For some reason System Restore was only set for about 200Mb on my 1Tb hard drive.

Any help please?

  a member 16:04 09 Dec 2009

Have you been into device manager , select DVD/CDROM drives, the rightclick the cd/dvd drive , and select properties ,try roll back driver ,this will install the previousely installed driver , if (rollback driver) is not available ,try update driver /browse my computer for software/ let me pick from a list of drivers . and hopefully you will see 2 or more compatible drivers , you will have to decide what one is the original .but once you choose and install check things out ,if you are ok then great if not ,go through the same routine and try the other driver .

  Icky 16:18 09 Dec 2009

Thanks for replying merlinx.

I've just tried your suggestion but get the message:
"Windows found driver software for your device but encountered an error while attempting to install it.
A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)
If you know the manufacturer of your device, you can visit it's website and check the support section for driver software."

Is there anything else I can try?

  a member 18:43 09 Dec 2009

the tesco software must have disabled a vital service ,in favour of its own go into services and see if you can locate it , Control panal/adminastrative tools/Services .see if you can find if anything relating to your DVD/CD has been switched off ,you can re-enable services here but if the tesco software has corrupted the registry ,you looking at bigger problems .

  Icky 18:46 09 Dec 2009

Thanks again for helping merlinx.

The only items disabled are:
Media Centre extender services,
Net.Tcp Port Sharing Service,
Routing and Remote Access.

Is therte anything else I can try or will I need to re-install Windows 7?

  a member 19:06 09 Dec 2009

if you have the installation disk you could try a repair, go through the sequence of installation and keep your eye out you will get the option to repair your installation without doing a full install .
are the drives empty ,or do you have CDs/DVDs in them(it) . I had a blank DVD in one of my drives a few months ago and restarted the PC the drive was not visable . I had the (hide empty drives) ticked in folder settings. though I did not think it would hide a empty blank DVD (it did) .

  Icky 19:15 09 Dec 2009

Oops --- I've just tried the Windows 7 installation disc but of course it doesn't work as the DVD drives are out of action.

  a member 20:07 09 Dec 2009

boot the computer with the disc in the drive it should work , make sure your bios is set to boot from CD/DVD

  Icky 20:19 09 Dec 2009

Thanks again for your help merlinx.

I'll do as you suggest in the morning when my head is clearer. It's spinning at the moment!!!
Wish my DVD drives were!

I'll let you know how I get on.

  powerless 23:20 09 Dec 2009

Whoa there...

click here

That will do it.

I've done this a few times on computers, it's easy and will fix it.

  Icky 08:27 10 Dec 2009

Thanks for helping Powerless.

I've just tried your suggestion but still with no luck.

When I look at the driver details there are two drivers.

The first one


When I highlight this it says

Provider: Microsoft Corporation
File version: 6.17600.16385(win7_rtm.090713-1255
Copyright: @Microsoft Corporation. All rights reserved.
Digital Signer: Microsoft Windows

The second one


When I highlight this it says

Provider: Sonic Solutions
File version: 2.03.30a
Copyright: [email protected] Sonic Solutions
Digital Signer: Not digitally signed

Is one of these wrong. Did it install with Tesco Easy Recorder?
If so how can I get rid of it? I've tried uninstalling the drivers.

Thanks again for any help before I re-install Windows 7.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Samsung Galaxy A8 review: Hands-on

Illustrator Juan Esteban Rodriguez on creating highly detailed official film posters for Star Wars…

iMac Pro review

Meilleurs drones (2018)