Directx problem?

  domhay 15:43 23 Oct 2011

System: Vista 32-bit Home Premium Intel(R) Core(TM)2 Duo CPU E6750 @ 2.66GHz Asus P5N32-E SLI Motherboard Asus NVIDIA GeForce GTX 560 Ti Graphics Card 3328 MB RAM

My old EVGA GTX8800 failed recently and I replaced it with an Asus GTX560 ti. I installed the latest BIOS (Revision 1903 17/11/2009, Chipset C55XEMCP55PXE), latest nvidia graphics card drivers (280.26). On running dxdiag the version of DirectX is 11 but under the display tab all directx features (DirectDraw, Direct3D, AGP Texture Acceleration) are described as "not available" - there is no option to enable them. The "Change Settings" button on the Display Settings -> Advanced Settings -> Troubleshoot is greyed out and it states "Your current display driver does not allow changes to be made to hardware acceleration settings". Any advice on this problem would be much appreciated.

  northumbria61 12:05 24 Oct 2011

Scroll down this link enter link description hereto find How can I force a full re-install of DirectX? I have no idea if this is what you are looking for or if it will work for you. Either make a a backup of your current registry settings for this or at least make a note of them so you can reverse the procedure if necessary.

  domhay 08:11 25 Oct 2011

Thanks for your advice.

I've tried what you suggested and I get the following message when I try and re-install DirectX:

An internal system error occurred. Please refer to DXerror.log and DirectX.log in your Windows folder to determine the problem.

I've tried looking for these log files but cannot find them in the Windows folder or anywhere else on my hard drive....

  northumbria61 22:19 25 Oct 2011

From what I read here it appears that the new Graphics card that you installed does not support DX11. The posts on this Forum LINK are from 2010 so I don't know if they still apply but have a read through enter link description here

  northumbria61 22:27 25 Oct 2011

Have a look in Device Manager and see if you have the option to "Roll back the Driver" for your Display Adapter (if not greyed out) although I can't say if this will help.

  northumbria61 23:00 25 Oct 2011

Another suggestion would be to run Microsoft Fix-It enter link description here DirectX is now an integral part of Windows so I am now wondering, in view of what you say "Your current display driver does not allow changes to be made to hardware acceleration settings". if you have an incorrect driver installed for your Graphics card. I suggested a roll back above but maybe an uninstall/reinstall to see if that helps.

  northumbria61 23:24 25 Oct 2011

I have checked the Nvidia site for your driver - I thought you may have downloaded the wrong one - ie: for 64bit instead of 32bit that you are running but I see they are both the same version 280.26

  domhay 20:40 31 Oct 2011

Thanks for all your responses. Nvidia released a new WHQL driver 285.62 a few days ago - I installed this and it seemed to sort out all the problems. It appears it wasn't directX after all.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

25 book design and illustration tips

iMac Pro review

Idées cadeaux pour geeks et tech addicts