Device descriptor request failed (error 43)

  Kino30 11:32 27 Aug 2016
Locked

Hello, this morning my keyboard stopped working and the device tab says the line in the title with a yellow triangle on it as well. Everytime i try uninstalling them and reinstalling the same thing pops up. All usb ports are up to date. I have desktop and the problem is only with my keyboard (corsair k95). all usb ports work and all other devices work in every port. The solutions in the youtube videos and forums don't work for me. I really want to fix this as my keyboard is only 2 months old. I am desperate to solve this please help me¨find what the problem is so I know if I can fix it or not.

Kind regards, Kino

  robin_x 13:25 27 Aug 2016

Presumably you also tried keyboard in the other ports.

Did you also try keyboard on another PC/laptop/tablet (via adapter)?

Try a System Restore on PC (Press Windows key and R and type rstrui )

Try USBDeview or USB Oblivion to clear stale entries

Create a Restore Point first (Win+R systempropertiesprotection )

  Kino30 14:02 27 Aug 2016

Thanks, I will try all those things and let you guys know if its solved

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Mi Mix 3 UK Review: Xiaomi's Flagship Slides Into The UK

12 character artists you should know about in 2019

iPad mini 5 release date, price & specs rumours

Test : l’enceinte Bluetooth BW-AS2 de Blitzwolf