desktop icons wont open with mouse

  cheddon 22:16 04 Jun 2012

hi i run winows 7 and when i log in i can open the desktop icons for a while but then they stop working and the mouse wont open them or right click on them and neither can i right click on the open desktop as nothing happens. any ideas? ive tried a system restore no good. when i restart hte computer its ok for a few minutes then the same problem again.

  rdave13 12:37 05 Jun 2012

Try going to power settings and change the plan to High Performance. Click change plan settings then select never for Turn off display and Put the computer to sleep. Click save changes. See if that helps.

  cheddon 12:49 05 Jun 2012

thanks for advising but its not that. i dont have a high performance option and a friend has identical laptop with same settings. thanks anyway

  rdave13 13:07 05 Jun 2012

If you have the time, before the freezing, type cmd in the start-search box. In the list that opens right click cmd and run as administrator.Type sfc/scannow in the cmd box and press enter. It will take a bit of time and hopefully will correct any errors if found. Once run type exit to close cmd.

  Barrington11 20:41 06 Jun 2012

I have Windows 7 Home Premium.

Two main problems I have had with Gadgets: 1) Vanishing Gadgets I think the solution was to Right click on the Desktop\Gadgets and if necessary 2) I have the following gadgets; Calendar, two clocks, System Mechanic, Norton Security and a weather 5 day gadget.

The weather appears to be an internet gadget. This means that if there is a problem with my broadband cable than it is disabled. What is strange is that the problem doesn't affect any of my other gadgets.

If it is a faulty internet problem (in my case with my Desktop) then nothing can be done until the internet connection is working properly.

However, if it isn't an internet problem, or you now have an internet which works properly, which in my case instead of having one weather gadget I had two over lapping each other when there should have only had one - My solution was to reinstalled the gadget: Right click Desktop. and I probably deleted the faulty gadget.

Hope it solves your problem.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

iMac Pro review

Illustrator Charles Williams on how to create magazines and book covers

iMac Pro review

Les meilleures prises CPL (2018)