Combat Flight Sim

  concise 00:42 28 Jun 2007

I have CFS3 running in Vista and it behaves impeccably with a Logitech Extreme 3D Pro Joystick. I loaded the original CFS which seems to run o.k. from the keyboard but ignores the joystick altogether. I have downloaded the latest drivers from Logitech to no avail.
Is there some technical reason for this and 'never the twain shall meet'?
Or is there a fix someone may know about to get it to run using this joystick?

  Seth Haniel 08:17 28 Jun 2007

CFS from there web site is not supported by Vista & vice-versa as is our Logitech Wingman Extreme 3D digital joystick

  concise 09:45 28 Jun 2007

Thanks for answering. The 3D Pro operates happily when running FS'X' and CFS3 (Haven't tried CFS2)with Vista.
CFS shows every sign of operating from the keyboard, it just doesn't seem to pick up the fact that the 3D Pro is connected. Strange.

  mrwoowoo 15:49 28 Jun 2007

this may sound silly,but....Have you tried starting the game and then pulling the game pad from the usb and plugging it back in immediately.
Sometimes this helps the game to pick it up.

  concise 21:32 28 Jun 2007

Thanks for the suggestion but no it won't have it. Even tried another stick without effect. I'm guessing it's something to do with the fact that the joystick is USB?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Sea of Thieves Review

Dell Canvas review: the cheap Wacom Cintiq alternative

How to use iMovie for Mac, tips and more

Comment filmer l’écran d’un iPhone ?