Water not flowing from electric shower

  ponytail 08:30 31 Dec 2016
Locked

Went to have a shower this morning but when I turned it on there was no water flowing.I could feel the water in the hose but nothing came from the shower head.I had this problem about three months ago and I descaled the head which seemed to work.This time I tried three different shower heads with the same result.Luckily we have a second shower.The shower is a Triton Cara 9.5kw.Luckily it is still under guarantee untill the 14th of Jan but just wondered if anyone could suggest something I could do/check before calling Triton.

  BRYNIT 08:51 31 Dec 2016

Have a read of CLICK HERE

  Forum Editor 09:04 31 Dec 2016

"I could feel the water in the hose"

Which will mean that water is leaving the shower unit, but is unable to exit via the shower-head.

Presumably you have detached the head, just to make sure that water then flows from the hose? If it does, the shower-head is obviously blocked with scale.

If you live in a hard-water area you are going to get scale forming in the showerhead nozzles, and regular descaling will be necessary.

  Govan1x 10:23 31 Dec 2016

If you take the shower head off and the water still does not flow you need a new Hose or whatever you call it.It is only a small plastic hose that goes through the middle and maybe it has been bent over causing the water to stop flowing.

So if you take the head off and the water does not flow you need a new Hose which are reasonably priced.

  ponytail 08:53 01 Jan 2017

I took the head off and it still did not so left it tried it a again a few hours later and it worked.I spoke to Triton and they seemed to think there must have been a small blockage of some kind but to keep a eye on it and if it happened again to try a new hose.

  Forum Editor 10:04 01 Jan 2017

Sometimes, scale from the heating element can become detached, and cause a blockage in the shower hose.

  oresome 11:28 01 Jan 2017

The fault is likely to be the solenoid that operates the water valve.

They can operate intermittently before failing entirely. You don't have to buy a complete assembly from Triton. Other suppliers will provide just the coil.

It is important that there are no water leaks above the coil. This is the likely cause of the failure in the first place and the new coil will fail in a similar manner if leaks are not attended to. (It may mean replacing the O rings on the parts above that push together.)

Obviously the electricity supply must be isolated before undertaking any work and also the water supply turned off.

  bumpkin 23:52 01 Jan 2017

Take the whole hose off not just the head and see if water flows then. If it does it is the hose, if not then oresomes suggestion is most likely.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

OnePlus 6T McLaren edition costs more and charges faster

Amy Cesal's Play-Doh infographics bring fun and colour to datavis

New Apple Products 2019: Predicting the new Apple products coming soon

Modifier un PDF : les meilleurs éditeurs PDF