Zone Alarm Problem

  accordion 11:17 16 Jul 2009

Here's a strange one. This morning, on startup, I get a message that validation has failed for two files:


Both used by Zone Alarm and both suggesting "You are probably missing a necessary root certificate".

So, I've done my research and done the following:

Scanned with NOD32 and MalwareBytes. All clean.
Reset the root certificates at click here
Downloaded and run rootsupd.exe
Cleared all temp files.
Defragmented 'C' drive.

Nothing has made any difference.

Then my wife turned on the laptop, and it's doing the same thing!

There hasn't been any updates to either computer, with the exception of NOD32.

The only other common factor is the router - so I rebooted it (I'll try anything).

The only 'fix' is from Zone Labs, and that means removing and reinstalling ZA. I don't think that's the answer though, not when both machines have shown the same problem at the same time.

So - has anybody else had problems? Especially if you have NOD32 alongside Zone Alarm.


  ashleycardwell94 11:28 16 Jul 2009

HAve you subscribed to Zonealarm - are you paying for it? if so then ZA might have downloaded courrupt updates and do both computers have ZA?

  accordion 11:42 16 Jul 2009

The ONLY program that will have updated on either machine is NOD32.

I always control updates with the exception of antivirus. So ZA will not update automatically.

I've already said that both computers have the same problem, it follows that both have ZA and both have NOD32.


  ukskydiver 13:07 16 Jul 2009

We have had the same issues which we're currently investigating.

We have an older version of Cisco VPN client (4.0.5D) and also an older version of Integrity Client (from memory)

Initial signs are that the certificate associated with the vsinit.dll and vsdata.dll is out of date.

If you look at the properties these files and check the certificate, (will require a bit of drilling down) you should notice that the cerificate ended at 1 second to 01:00 this morning 16/07/09. This is Verisign Class 3 Code Signing 2004 CA.

I'm not sure why the cert update that you mentions does, nor why it doesn't work.

It looks like, but we are still testing, getting hold of later versions of VSINIT.DLL VSDATA.DLL and VSDATANT.SYS and copying over the top of the file in Windows\SYSTEM32 does the job

*Disclaimer: I'm not telling you to follow this advice. I am merely telling you our findings thus far. Act upon it at your own risk.

  accordion 14:14 16 Jul 2009

That's interesting. I have had a customer call me with two more machines doing the same.

I have tried uninstalling ZA and reinstalling, didn't fix anything. In fact, Windows still thinks that ZA is running!

To make matters worse, ZA on the other machines is still running in the background, but you can't do anything to give permissions to any programs - like the update to FF that was installed on one machine and now cannot get any Internet.

Let me know if you are able to track down later versions of the dll files (and from where) - assuming it fixes the issues.


  reneed 15:25 16 Jul 2009

This morning I had the same problem on two pc's. I was not possible to remove the program. (version 6 of zonealarm)

After reading the information about the validation date the solution was simple. I set the date tot 13 juli 2009, put the pc out and on again. The problem was fixed and it was possible to remove the old version of the zonealarm program. Now i put the latest version om my pc.


  accordion 15:41 16 Jul 2009

I have been down a different route, end result the same. I had to remove a few extra files related to Zone Labs from the system 32 folder.

Now I've been able to install version 8 of ZA.

Now, I'm hoping that the Internet isn't going to be 'lost' when browsing after about five minutes.

We shall see ........


  ukskydiver 15:45 16 Jul 2009

Installing from your previous installer would just install the same version of files, surely?

We are in the process of updating a number of software components, so we already had a later version of the DLL files.

You will have to try going via CheckPoint / Cisco to get the correct files.

We were able to diagnose the issue by changing the date too. This meant that we verified that it was date related.

  accordion 16:55 16 Jul 2009

Actually, I have three versions of Zone Alarm stashed on my data drive. Other versions downloaded for various customers. Just never updated my own.

I fixed it in Safe Mode eventually.

After unistalling ZA, removed a few extra files from the system 32 folder:


Then I was able to install the later version and all is well again.


  reneed 21:43 16 Jul 2009

@ukskydiver, because you said it was a time/date problem, so a date problem, I fixed it. So thanks for your remark.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review: Hands-on

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?