XPpro ghost users after system recovery

  cga 12:06 08 Jul 2004

I wont go into the full sequence of events but I needed to recover my system last weekend and the only way this could be acheived was by an "upgrade" install from the original XPPro CD.
After the reinstall I was in Administrator and redefined one of my users (I took an extra copy of the complete Documents and settings first). When I tried to Log off/Log on I came to the user selection screen with no users showing.
OK - I went back into Administrator and created 2 new userids (TEST1 & TEST2). This time no problem - they appeared on the signon screen.
I now renamed the directory structure for each of the 3 main users, recreated them and logged on to check them - All Ok.
From Administrator I ten copied save complete saved directory structures back in for these 3 users.
Result - these 3 users work fine with no data loss and even the outlook identities work correctly.
I now tried to delete users TEST1 & TEST2 but it appears these do not have directory structures of their own under Documents & Settings asnd are sharing the files in my other 2 user directory structures.
Finally - I have tried recreating the original user that I defined and - whatever I do - this does not create a directory structure in D&S and does not appear on the menu list.

Any ideas how I can clean up this situation

  AndySD 13:55 08 Jul 2004

Are they listed under local users in computer managment console (Right Click on My Computer and choose Manage)and can you delete them form there.

  cga 14:16 08 Jul 2004

Yes - I have tried that. The result depends on which case.

TEST1/TEST2 (overlapping file use) I can say delete and it starts but then fails because of file sharing problems.

LYN (This is the user I redefined but does not appear on the menu). Yes it appears in the list and I can delete it. When I try to redefine it (even after system restart) I still have the same problem of it only being half there (no directory in Documents and settings and no ICON on the sign on).

Somehow the pointers seem to have been corrupted by the recovery but I dont know how to correct this.

  AndySD 15:28 08 Jul 2004

ok start with the windows file cheker (sfc)

Put your windows CD into the CD ROM and hold the shift key (the one with arrow pointing up, just above the Ctrl key on the left of your keyboard). Holding shift for a few seconds will stop the Windows CD from auto running, but the drive will still spin up to read the disk then spin back down again. Once it has spun down you can release the shift key.

Now click Start/All Programs/Accessories and choose Command Prompt. Type in

sfc /scannow

and hit enter. This will check and replace any damaged system files.

  cga 21:09 08 Jul 2004

Thanks Andy for your very detailed instructions on running sfc.
I had not considered this as I had just done an upgrade install + all the service pack etc. and would have expected any problems to be found.
Anyway - no stone unturned - so I just tried it. Unfortunately with no avail.
Any other suggestions you have are welcome - I suspect that it needs something to look specifically at the user pointers aqnd I don't know of any tool that does that.

  cga 14:57 13 Jul 2004

Problem now resolved (but not solved). No idea how this happened but the way i solved it was.
1. Back up everything in sight.
2. Use Administrator to delete TEST1 & TEST2 keeping files.
3. Checked the files that were kept - these belonged to my two main users.
4. Restored the document & settings folders for the two main users.
5. Checked it out - everything now OK
6. Strangely I can now create additional users OK
Seems pointers were screwed up somewhere and this fixed it.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

HTC U12 Plus review: Hands-on

Best Android emulators for Mac

TV & Streaming : comment regarder Roland Garros ?