XP Vista Network problems

  Catastrophe 14:15 15 Sep 2008

I have 3 computers networked:

C3 XP home C4 XP prof C5 Vista
None is connected to the Internet.

I had some "network cable unplugged" problems but buying a new switch (Pluscom 5 port) overcame these. The power light is on and both green lights are on for each of the 3 connections (not blinking).

C4 is showing:
"Local Area Connection 3
Limited or no connectivity"
Status gives:
"This problem occurred because the network did not assign a network address to the computer" although I understand there may be several causes for this message.
(C3 is giving similar problems but I dod not have mouse/keyboard/monitor connected at the moment. I changed these from C3 to C4).
From here details shows:
"Physical address 00-00-E8-15-A7-38
IP address
Subnet mask
Default gateway (blank)
DNS server (blank)
WINS Server (blank)

C5 (Vista)shows the C5 icon and components
It says "Unidentified Network (1)
In all cases network is set to MSHOME

I fitted a new Fast Ethernet 10/100M PCI LAN Adapter in one PC but new hardware was not found even though there is a small driver CD. Would such not be installed by XP or Vista.

The fact that none of the PCs are networked suggests there is something fundamental I have not done or perhaps all three cables are fualty?

I do not have any AV or firewalls running on these PCs.

Any suggestions gratefully received.

  brundle 14:24 15 Sep 2008

Is there a router involved in any of these connections? Your previous thread which DieSse so helpfully answered did create a little ambiguity for me - what is connected to what, and what isn't connected. (click here for any body else).

  Catastrophe 14:30 15 Sep 2008

Hi brundle

Each computer has a PCI card adapter. There are no modems or Internet connections. Each PC is connected (by cables which previously worked fine)to Pluscom switch model N5P-RTL8305SC.

Hope this answers your question?


  brundle 14:30 15 Sep 2008

If you have a switch and no router the machines will automatically choose APIPA addresses in the 169.254.x.x range so that they can communicate using TCP/IP without requiring manual configuration - a router would act as a DHCP server and provide private addresses for the networked machines, most often starting 192.168.x.x , or 10.x.x.x or 172.16.x.x.

The error message is telling you that the machine looked for a DHCP server but couldn't find one, so assigned an APIPA address.

Did you leave the driver-less card in the machine? You won't get anywhere with that PC if you can't install the drivers.

  brundle 14:36 15 Sep 2008

Check each machine, what is the 169.x.x.x address for each one? Open a command prompt and ping one machine from another - if the ping is successful, from that same machine (the one you issued the ping from), again at the command prompt, type

arp -a

What do you see?
You can copy and paste sections from a command prompt window; click here

Do it from an XP machine, saves any problems with permissions on Vista

  Catastrophe 14:44 15 Sep 2008

"Did you leave the driver-less card in the machine? You won't get anywhere with that PC if you can't install the drivers."

Yes all cards are in respectivre machines.

From Crossbow on Friday:

"Sometimes it's not done & you have to do it manually. Check if the network adapter/PCI card is showing up in Device Manager > Network adapters (it's NOT the '1394 Net Adapter'), & there are NO exclamation marks there."

I did not check this when other problem was solved. I just checked on C4 and find ADMtec PCI adapter is said to be working properly. I disabled the previous PCI SiS900 adapter whicjh is shown with a red cross.

Shall I remove card/boot/power off and reinstall card in the hope new hardware might be recognised?

  Catastrophe 14:45 15 Sep 2008

Message crossed. Will ping and revert.

  Catastrophe 15:01 15 Sep 2008

Still looking for address on C5 but meanwhile C4 and C5 device managers report working properly and show drivers as present.

  Catastrophe 15:22 15 Sep 2008

I have three addresses on C5
IP address
Default gateway and DNS server

They all give: Destination host unreachable

  Catastrophe 15:37 15 Sep 2008

Going from C5 to C4 they all time out 00% loss.

  brundle 15:59 15 Sep 2008

OK you wont get a response from the machine using an APIPA address (169.254) as it's not getting a DHCP address in the same manner as the others - which appear to be using a router as a DHCP server, or are using static IPs.
What does `Default Gateway` say on C5? Which machines are set to use DHCP, which machines have IP addresses set manually?

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Huawei MateBook X Pro review

8 digital brands that designed custom typefaces to save millions

How to speed up a slow Mac

Comment résoudre des problèmes d’impressions ?