XP system won't switch off

  johnem 22:39 03 Jan 2007

Evening all, back for some more advice. System running Window XP Pro SP2 has recently decided that it will not switch off or change users from the "Start" button. Only way is to press and hold in the power button. I have started in "Safe Mode", defraged the hard drive, run CCleaner, Regseeker and RegscrubXP. Tried starting in "Last known good working". All to no avail. I cannot think that any newe software has been installed, just the normal McAffee, Spysweeper, Spybot and Zonealarm updates.
Any suggestions that I can try to restore normal operation.

  skidzy 22:47 03 Jan 2007

click here and click here as a workaround.

  Rtus 22:49 03 Jan 2007

click here

and Google > a few hints at Norton internet utilities causing this kind of bother

  skidzy 22:50 03 Jan 2007

and click here

You could also try the system file checker:

Start/Run and type sfc /scannow
Understanding SFC click here

  johnem 23:25 03 Jan 2007

skidzy and Rtus, thanks for the info, down to some serious reading me thinks.

  johnem 21:13 04 Jan 2007

Evening all,
I tried to run sfc /scannow and received message that incorrect version of windows was on the cd. Followed the thread above and copied the I386 folder onto root of "C" drive and modified registry. Ran sfc /scannow again, showed the same message. Tried to use system restore, all 5 available restore points could not be utilised. Tried rebooting the system, wont reboot without presing the reset button. Have updated virus definitions and run full search, no viruses found. Run spycheck, Zonealarm syware check and spy sweeper, no faults found.
At a slight loss now, any further suggestions?

  Mr Mistoffelees 21:41 04 Jan 2007

There may be something here to help you click here

  johnem 23:39 04 Jan 2007

Mr Mistoffelees,
Thanks for the info, have tried some of the relevant ones to no avail. Have decided to do a "Windows Repair". This has now completed, but has not solved the problem. Noticed during install that system was unable to find/load several .dl_ files, just had to tell it to cancel about 30 times. Everything seems to be functioning, just dowloaded the 64 MS updates. Puter will still not log off or close down from the start button or from task manager.
Any further ideas please?

  Stuartli 00:36 05 Jan 2007

I occasionally get this problem - however I found out that it's due to IOBitSmartDefrag closing down properly (it runs in the background defragging the hard drive if there is little CPU use).

  WXMAN 09:57 05 Jan 2007

Go to regedit,
key local machine/system/current control set/control/session manager/memory management/



  johnem 20:30 05 Jan 2007

Stuartli and WXMAN, thanks for your help, have checked both of these, have disabled "auto defrag" in IOBit and the ""clear page" is set at 0.
Have just noticed that probably as a rresult of the repair attemopt last night, if I click on internet Explorer on the desktop it just creates a new shortcut to IE and does not open. If I click on the icon in the quick launch area, IE opens up as normal.
Think that the dreaded reformat/install time is rapidly approaching, ho hum. It would have helped if I had got round to having a fully running and stable system and had implemented the Acronis total "C" drive back up. Maybe next time. Thanks for your help.

This thread is now locked and can not be replied to.

Elsewhere on IDG sites

Dell XPS 13 9370 (2018) review

The art of 'British' pulp fiction

Best password managers for Mac

TV & streaming : comment regarder le Tournoi des Six Nations 2018 ?